9.부록

9.1Project Explorer Icon

Project Explorer에서 표시되는 아이콘은 다음과 같은 의미를 가집니다

표 9-1Project Explorer Icon

메뉴

기능

Project

Project

TypeDefinition

Form이 실행되기 위한 Configure 정보들

Updates

Update 그룹

Update

Update

Components

Component 그룹

Component

TypeDefinition에 정의된 컴포넌트

GlobalVariables

전역변수

Variables

Variable 그룹

Variable

변수

Datasets

Dataset 그룹

Dataset

Dataset

Column

Dataset에 사용된 Column 정보

Images

Image 그룹

Image

Project에 사용된 Image

ADL

ADL

MainFrame

Project의 MainFrame

ChildFrame

MainFrame내의 Frame구성 정보

Styles

Style 그룹

Style

Style 정보

Themes

Theme 그룹

Theme

Theme 정보

ScreenInfo

Screen 그룹

Screen

Screen 정보

Forms(FDLs)

서비스 그룹

Form(FDL)

Form 정보

Layout

Form Design에 표시되는 컴포넌트 그룹

Script

Form의 Script에 선언된 Func 그룹

Func

Script에서 선언된 Func Item

Bind

BindItem 그룹

BindItem

각 Bind 항목 정보

9.2Toolbar 기능툴바:세부 기능

넥사크로 스튜디오는 다양한 기능을 Toolbar형태로 지원하고 있습니다.

9.2.1Standard툴바:세부 기능:Standard

Standard Bar는 넥사크로 스튜디오가 제공하는 기본 기능을 모아놓은 곳입니다.

그림 9-1Standard Bar

표 9-2Standard Bar

메뉴

기능

Open Project

Project 열기

Open

넥사크로 스튜디오에서 편집 가능한 형식의 파일 열기

New

새로운 Project나 Form, User Component, css, xml, xjs등을 생성

Save

현재 열린 Form문서 저장

Save All

현재 열린 모든 Form문서 저장

Cut

선택 영역을 잘라내어 클립보드에 저장

Copy

선택 영역을 복사해서 클립보드에 저장

Paste

클립보드에 저장된 내용 붙여 넣기

Print

현재 문서 인쇄

Options

넥사크로 스튜디오의 Options창 표시

Help

Help

9.2.2Build툴바:세부 기능:Build

프로젝트/폼 단위 빌드 관련 툴바입니다. nexacrogenerator.exe와 연동된 부분에 대한 처리와 넥사크로플랫폼 애플리케이션 실행 부분을 담당합니다.

표 9-3HTML5 Bar

메뉴

기능

1

Generate Application

프로젝트 전체를 자바스크립트 파일로 변환합니다. 변환된 파일은 옵션에서 지정된 폴더나 대화상자에서 선택된 폴더에 저장됩니다.

2

Generate Theme

선택된 테마를 자바스크립트 파일로 변환합니다.

3

Generate Service

선택된 서비스 그룹을 자바스크립트 파일로 변환합니다.

4

Generate File

편집 중인 Form 파일을 자바스크립트 파일로 변환합니다.

5

Generate Modules

BaseLib 경로에 있는 모듈 항목 중 고정된 항목(Framework, Resource)과 Typedefinition에 정의된 항목을 Generate 경로에 복사합니다.

6

Stop Generate

진행 중인 변환 작업을 중지합니다.

7

ADL

활성화된 ADL를 표시합니다.

8

Theme

활성화된 ADL에서 사용하고 있는 테마를 표시합니다.

9

Screen

실행 시 사용할 Screen 정보를 선택합니다.

10

Web Browser

애플리케이션 실행 시 사용할 실행 환경을 선택합니다.

넥사크로플랫폼 런타임과 사용자 PC에 설치된 웹브라우저 중에서 선택할 수 있습니다.

11

Launch Project

활성화된 프로젝트를 실행합니다.

12

QuickView

활성화된 Form을 실행합니다.

넥사크로 스튜디오에서 Generate 명령 실행 시 메뉴[Build > Deploy > Deploy Application]에 설정된 "Merge JSON file" 옵션 체크 여부에 따라 Merge 기능을 적용합니다.

9.2.3Deploy

표 9-4HTML5 Bar

메뉴

기능

Deploy Application

서버에 이관할 파일을 자바스크립트 파일로 변환합니다.

• 애플리케이션, 테마, 파일, 모듈(라이브러리) 단위로 변환할 수 있습니다.

• 필요에 따라 자바스크립트 파일을 압축(난독화)해서 변환할 수 있습니다.

('Compress JS Files' 항목 체크 / JDK 설치 필요)

Deplpoy Themes

Deplpoy Files

Deplpoy Modules

Make Application Archive

Make Bootstrap, Make File Archive, Make Theme Archive 기능을 한번에 처리할 수 있는 기능을 제공합니다.

Make Bootstrap

앱을 구동시키는 Run.html을 포함한 Run.zip 및 start_android[ios].json 파일을 만드는 기능입니다.

Make File Archive

프로젝트 파일을 아카이브 파일로 만들고 TypeDefinition에 배포에 필요한 정보를 등록하는 기능입니다.

Make Theme Archive

테마 파일을 아카이브 파일로 만드는 기능입니다.

9.2.4Align툴바:세부 기능:Align

Align Bar는 Form화면 개발 시 컴포넌트 정렬 기능을 모아놓은 곳입니다.

그림 9-2Align Bar

표 9-5Align Bar

메뉴

기능

Align Lefts

마지막에 선택한 컴포넌트의 Left 값을 기준으로 정렬

Align Centers

마지막에 선택한 컴포넌트의 수평 Center 값을 기준으로 정렬

Align Rights

마지막에 선택한 컴포넌트의 Right 값을 기준으로 정렬

Align Tops

마지막에 선택한 컴포넌트의 Top 값을 기준으로 정렬

Align Middles

마지막에 선택한 컴포넌트의 수직 Center 값을 기준으로

정렬

Align Bottoms

마지막에 선택한 컴포넌트의 Bottom 값을 기준으로 정렬

Same Width

마지막에 선택한 컴포넌트의 Width 값을 기준으로 너비를 맞춤

Same Height

마지막에 선택한 컴포넌트의 Height 값을 기준으로 높이를 맞춤

Same Size

마지막에 선택한 컴포넌트의 Size를 기준으로 크기 맞춤

Space distribute Horizontally

컴포넌트 사이를 같은 수평 간격으로 분배 배치.

처음과 끝 컴포넌트 사이의 공간을 수평으로 분배하여 균등한 간격으로 컴포넌트를 재배치합니다.

Space distribute Vertically

컴포넌트 사이를 같은 수직 간격으로 분배 배치.

처음과 끝 컴포넌트 사이의 공간을 수직으로 분배하여 균등한 간격으로 컴포넌트를 재배치합니다.

Same space Horizontally

컴포넌트 사이를 같은 수평 간격으로 정렬 배치.

사용자가 직접 편집창에서 컴포넌트의 간격을 조절할 수 있습니다


Same space Vertically

컴포넌트 사이를 같은 수직 간격으로 정렬 배치.

사용자가 직접 편집창에서 컴포넌트의 간격을 조절할 수 있습니다


Posit Center

선택한 컴포넌트들을 Form Canvas의 수평 Center로 이동

Posit Middle

선택한 컴포넌트들을 Form Canvas의 수직 Center로 이동

Posit Left

선택한 컴포넌트들을 Form Canvas의 Left로 이동

Posit Right

선택한 컴포넌트들을 Form Canvas의 Right로 이동

Posit Top

선택한 컴포넌트들을 Form Canvas의 Top으로 이동

Posit Bottom

선택한 컴포넌트들을 Form Canvas의 Bottom으로 이동

Bring to Front

선택한 컴포넌트를 맨 앞으로 가져오기

Send to Back

선택한 컴포넌트를 맨 뒤로 보내기

Bring Forward

선택한 컴포넌트를 앞으로 가져오기

Send Backward

선택한 컴포넌트를 뒤로 보내기

Arrange to Taborder

컴포넌트 tab order 순서대로 Z-Order를 변경하기 위해 소스 코드를 재배치

Position Editor

선택한 컴포넌트의 position 속성을 편집할 수 있는 Position Editor 실행

Lock Control

컴포넌트의 위치를 마우스로 이동하지 못하도록 고정시키거나 해제

9.2.5TextStyle툴바:세부 기능:TextStyle

TextStyle Bar는 Form화면 개발 시 선택된 컴포넌트의 TextStyle 설정 기능을 모아놓은 곳입니다.

그림 9-3TextStyle Bar

표 9-6TextStyle Bar

메뉴

기능

Font Name

글꼴 이름 변경

Font Size

글꼴 크기 변경

Bold

텍스트를 굵게 표시

Italic

텍스트를 기울임 꼴로 표시

Strikeout

취소줄 표시

UnderLine

텍스트에 밑줄 표시

Anti-Alias

텍스트를 매끄럽게 표현

Front Size Up

글꼴 크기 늘림

Front Size Down

글꼴 크기 줄임

Text Align Left

텍스트를 왼쪽에 맞춤

Text Align Center

텍스트를 가운데 맞춤

Text Align Right

텍스트를 오른쪽에 맞춤

Text Align Top

텍스트를 위쪽에 맞춤

Text Align Middle

텍스트를 중간에 맞춤

Text Align Bottom

텍스트를 아래쪽에 맞춤

9.2.6Objects툴바:세부 기능:Objects

Objects Bar는 TypeDefinition에 등록된 컴포넌트 모임입니다. 화면 편집에 해당 컴포넌트를 직접 끌어다 놓음으로써 화면을 구성할 수 있습니다.

그림 9-4Objects Bar

표 9-7컴포넌트

아이콘

이름

설명

Select

하나 이상의 컴포넌트를 마우스로 드래그해서 선택합니다.

Div

Form안에 다른 Form을 불러와서 하나의 Form인 것처럼 사용하거나, 관련 있는 컴포넌트들을 하나의 그룹으로 묶어서 처리할 경우 사용되는 컴포넌트

Button

사용자로부터 마우스 입력을 받을 때 사용하는 컴포넌트

PopupDiv

하나의 화면에 여러 개의 부분화면을 구성할 때 사용

Combo

Edit와 Drop down List를 통합한 형태의 컴포넌트

CheckBox

Check 표시에 대한 TRUE/FALSE 값을 가지는 컴포넌트

ListBox

항목을 목록으로 나열한 후 선택할 경우 사용되는 컴포넌트.

Edit

문자열의 입출력을 가지는 컴포넌트

MaskEdit

날짜의 연월일시(yyyy/mm/dd hh:mi:ss) 형식 또는 숫자의 콤마 표시와 같이 규정된 형식으로 문자열의 입출력을 가지는 컴포넌트

TextArea

여러 줄의 문자열의 입출력을 가지는 컴포넌트

Menu

Menu 아이템을 구성할 경우 사용되는 컴포넌트

Tab

한 화면에서 여러 개의 Tab page를 분할할 경우 사용되는 컴포넌트

ImageViewer

화면에 이미지를 표시할 때 사용되는 컴포넌트

Radio

제시된 여러 가지 선택사항 중에서 하나의 항목을 선택해야 할 경우 사용되는 컴포넌트

Calendar

날짜를 입력할 때 사용되는 컴포넌트

Static

고정된 텍스트를 표시할 때 사용되는 컴포넌트

Grid

스프레드 시트와 유사하게 Dataset의 내용을 표 형식으로 처리하는 컴포넌트

Spin

정해진 규칙에 따라 손쉽게 숫자를 입력 받을 때 사용하는 컴포넌트

PopupMenu

PopupMenu를 구성할 경우 사용되는 컴포넌트

GroupBox

화면을 구성할 때 관련 있는 컴포넌트들을 그룹화하는 컴포넌트

ProgressBar

작업의 현재 진행 상태를 그래픽을 이용하여 보여주는 컴포넌트

Plugin

Plugin을 사용할 경우 사용되는 컴포넌트

Dataset

데이터를 테이블 형태로 저장하는 컴포넌트

9.2.7Debug

Debug Bar는 디버깅 시 필요한 기능을 모아 놓은 곳입니다.

표 9-8Bookmark Bar

메뉴

기능

Debug Project

프로젝트 디버깅 모드 시작

Debug Form

현재 선택된 Form의 디버깅 모드 시작

Restart Debugging

디버깅 모드 재시작

Stop Debugging

디버깅 모드 종료

Step Into

한 스탭씩 디버그 작업 진행

다른 함수 호출 시 해당 함수로






이동

Step Over

현재 함수의 나머지 부분을 실행하고, 함수 호출이 이루어진






다음 문장에서 멈춤

Step Out

한 스탭씩 디버그 작업 진행

현재 스탭을 모두 실행하고, 다음 스탭으로 이동

Run to Cursor

현재 커서가 위치한 줄까지 실행 후 멈춤

Toggle Breakpoint

브레이크 포인트를 설정/해제하는 기능

Delete Selected Breakpoint

브레이크 포인트 목록 창을 활성화하고 선택된 브레이크 포인트를 제거

Delete All




Breakpoints

설정된 모든 브레이크 포인트를 제거

Go To Source

브레이크 포인트 목록 창을 활성화하고 선택된 브레이크 포인트의 소스 코드 위치로 이동

Enable/Disable All Breakpoints

설정된 모든 브레이크 포인트를 활성화/비활성화하는 기능

9.2.8Bookmark툴바:세부 기능:Bookmark

Bookmark Bar는 Script 또는 Source 편집 중에 특정 줄로 쉽게 이동할 수 있는 Bookmark 기능을 모아놓은 곳입니다.

그림 9-5Bookmark Bar

표 9-9Bookmark Bar

메뉴

기능

Toggle Bookmark

현재 커서 위치에 Bookmark를 설정 및 해제

Previous Bookmark

이전 Bookmark를 찾아 커서를 위치

Next Bookmark

다음 Bookmark를 찾아 커서를 위치

Previous Bookmark in Document

현재 편집 창에서 이전 Bookmark를 찾아 커서를 위치

Next Bookmark in Document

현재 편집 창에서 다음 Bookmark를 찾아 커서를 위치

Clear Bookmarks

설정된 Bookmark를 모두 해제

Clear Bookmarks in Document

현재 편집 창에서 설정된 Bookmark를 모두 해제

9.2.9CSS Selector툴바:세부 기능:CSS Selector

각 Selector의 추가/삭제 등의 기능을 모아놓은 곳입니다.

표 9-10CSS Selector Bar

메뉴

기능

Go to Source

선택된 Selector의 Source Code 위치로 이동. Selector을 Double Click하여 동일한 기능을 수행 가능

New Selector

신규 Selector 입력

Add Child Selector

선택된 Selector에 Child Selector를 추가

Delete

선택된 Selector를 삭제

Rename

선택된 Selector의 이름 바꾸기

Compress All

사용되지 않는 모든 Property를 제거

Uncompress

선택된 Selector의 Property를 모두 표시

9.3Menu Bar

Menu Bar는 넥사크로 스튜디오에서 제공하는 기능을 모아놓은 곳입니다.

그림 9-6Menu Bar

9.3.1File메뉴바:File

표 9-11File Menu

메뉴

기능

New

• Project - 새로운 Project 생성

• Form - 새로운 Form 생성

• File - 새로운 File 생성


• Style Sheet(.css) - 현재 Project에 새로운 Style Sheet 파일생성

• XML(.xml) - 현재 Project에 새로운 XML 파일생성

• Script (.xjs) - 현재 Project에 새로운 xjs파일 생성

• XTheme(.xtheme) - 현재 Project에 새로운 Theme파일 생성

Open

• Project - Project 새로 열기

• File… - 넥사크로 스튜디오에서 편집 가능한 형식(xjs, css, xfdl, xtheme 등)파일 열기

Close

현재 열린 Form 닫기

Close Project

현재 열린 Project 닫기

Save

현재 활성화된 편집 화면을 저장하기

Save As…

현재 활성화된 편집 화면을 다른 이름으로 저장하기

Save All

현재 열린 모든 편집 화면 및 Project Explorer에서 변경된 모든 내용을 저장하기

Recent Files

최근에 Open한 File 목록을 표시

Recent Projects

최근에 Open한 Project 목록을 표시

Import…

다른 Project에서 사용중인 xfdl을 현재 Project로 Import 하거나 [Export Project] 기능으로 생성된 Export Project파일을 Import하여 신규 프로젝트를 생성하는 기능

Export Project

현재 열린 Project를 File로 Export

Project Template

현재 열린 Project를 Project Template로 등록, 신규 Project 생성시에 재사용 가능

Screen Template

Screen Template 등록, Screen Template을 등록하여 새로운 Form을 생성할 때 등록된 Template을 적용가능

Print

Source 또는 Script의 텍스트를 출력

Print Setup

출력 페이지 설정

Exit

넥사크로 스튜디오 종료

9.3.2Edit메뉴바:Edit

표 9-12Edit Menu

메뉴

기능

Undo

최종 단계의 이전 상태로 되돌림

Redo

Undo하기 이전 상태로 되돌림

Cut

선택된 영역을 잘라서 클립보드에 삽입

Copy

선택된 영역을 클립보드에 삽입

Paste

클립보드에 있는 내용을 붙여 넣기

Paste Special

클립보드에 있는 컴포넌트의 Property 및 Bind정보를 사용자가 선택하여 붙여 넣기

Delete

선택된 컴포넌트나 선택된 영역의 텍스트삭제

Select All

Source나 Script 창에서 모든 텍스트 선택

Find…

Source나 Script 창에서 문자열 찾기

Find in File…

지정경로의 파일들 중 지정단어를 포함한 파일 찾기

Replace

Source나 Script창에서 특정 문자열을 다른 문자열로 교체

Goto Line…

Source나 Script창에서 특정 라인으로 커서 이동

Bookmark

Bookmark메뉴에서 제공하는 기능은 Toolbar[Bookmark Bar]의 기능과 동일.

Comment

Selection

Source나 Script창에서 선택된 영역의 문자열을 주석처리

UnComment

Selection

Source나 Script창에서 선택된 영역의 문자열의 주석해제

Refresh File

Status

파일을 Reload

9.3.3View메뉴바:View

그림 9-7View Menu

표 9-13View Menu

메뉴

기능

Toolbars


• Standard - Standard Toolbar를 표시/숨김

• Build - Build Toolbar를 표시/숨김

• Deploy - Deploy Toolbar를 표시/숨김

• Align - Align Toolbar를 표시/숨김

• TextStyle - TextStyle Toolbar를 표시/숨김

• Objects - Objects Toolbar를 표시/숨김

• Debug - Debug Toolbar를 표시/숨김

• Bookmark - Bookmark Toolbar를 표시/숨김

• CSS Selector - CSS Selector Toolbar를 표시/숨김

Toolbox

Component Toolbox를 표시/숨김

Statusbar

Statusbar를 표시/숨김

Project

Explorer

Project Explorer창을 표시. Project Explorer창이 열려있을 때는

focus만 이동

Properties

Properties창을 표시. Properties창이 열려있을 때는 focus만 이동

Style Property

Editor

Style Property Editor창을 표시. Style Property Editor창이 열려있을 때는 focus만 이동

Output


• Message - Output창을 표시

• Find Result1 - Find Result1창을 표시

• Find Result2 - Find Result2창을 표시

• Global Bookmark - Global Bookmark창을 표시

9.3.4Assist메뉴바:Assist

표 9-14View Menu

메뉴

기능

Copy Full Path

선택된 파일이 저장된 경로를 클립보드에 복사

Open Containing Folder

선택된 파일 또는 폴더 위치를 윈도우 탐색기를 열어서 보여줍니다

Open File in Project

프로젝트 내 포함된 파일을 검색하고 직접 실행할 수 있습니다.

9.3.5Design메뉴바:Design

그림 9-8Design Menu

표 9-15Design Menu

메뉴

기능

Align


Align메뉴에서 제공하는 기능은 Toolbar[Align Bar]의 기능과 동일. (Align 설명 참조)

Space


Space메뉴에서 제공하는 기능은 Toolbar[Align Bar]의 기능과 동일. (Align 설명 참조)

Size


Size메뉴에서 제공하는 기능은 Toolbar[Align Bar]의 기능과 동일. (Align 설명 참조)

Position


Position메뉴에서 제공하는 기능은 Toolbar[Align Bar]의 기능과 동일. (Align 설명 참조)

Arrange


Arrange메뉴에서 제공하는 기능은 Toolbar[Align Bar]의 기능과 동일. (Align 설명 참조)

Zoom


현재 열려있는 화면의 확대/축소 비율 설정

Layout Resize


Default Layout을 기준으로 자동 또는 입력값만큼 컴포넌트의 크기가 Resize됩니다.

Position Editor

선택한 컴포넌트의 위치값을 지정할 수 있는 Position Editor 창을 엽니다.

Tab Order

Editor

Tab Order 순서를 지정하고 테스트할 수 있는 Tab Order Editor 모드를 실행합니다.

Tab Order List

Tab Order 순서를 지정할 수 있는 Tab Order List 창을 엽니다.

Tab Order View

Form Design 화면에 컴포넌트의 Tab Order와 Z-Order 표시 여부를 토글로 지정합니다.

Show Bind

State

컴포넌트의 Bind 상태를 표시

9.3.6Build메뉴바:Build

그림 9-9HTML5 Menu

표 9-16HTML5 Menu

메뉴

기능

Generate Application

프로젝트 전체를 자바스크립트 파일로 변환합니다. 변환된 파일은 옵션에서 지정된 폴더나 대화상자에서 선택된 폴더에 저장됩니다.

Generate Themes

선택한 테마를 자바스크립트 파일로 변환합니다.

Generate Service

선택된 서비스 그룹을 자바스크립트 파일로 변환합니다.

Generate File

편집 중인 Form 파일을 자바스크립트 파일로 변환합니다.

Generate Modules

BaseLib 경로에 있는 모듈 항목 중 고정된 항목(Framework, Resource)과 Typedefinition에 정의된 항목을 Generate 경로에 복사합니다.

Stop Generate

진행 중인 변환 작업을 중지합니다.

Deploy

• 서버에 이관할 파일을 자바스크립트 파일로 변환합니다.

• 애플리케이션, 테마, 파일, 모듈(라이브러리) 단위로 변환할 수 있습니다.

• 필요에 따라 자바스크립트 파일을 압축(난독화)해서 변환할 수 있습니다.

('Compress JS Files' 항목 체크 / JDK 설치 필요)

Compress

프로젝트를 Compress된 자바스크립트 파일로 저장합니다.


Compile

프로젝트 또는 지정한 코드를 난독화된 파일로 저장합니다.

- Project


- File

Launch Project

활성화된 프로젝트를 실행합니다.

QuickView

활성화된 Form을 실행합니다.

Deploy 메뉴에서 'Compress JS Files' 기능을 사용하기 위해서는 자바 실행 환경(JDK)이 실행되는 PC에 설치되어 있어야 하고 실행에 필요한 환경 변수를 설정해주어야 합니다.

JDK 1.5 이상 버전을 설치하는 경우에는 실행에 필요한 환경 변수(JAVA_HOME)를 따로 설정해주지 않아도 시스템 경로에 자동으로 실행 파일을 복사해 접근할 수 있습니다.

9.3.7Archive메뉴바:Archive

그림 9-10archive_menu

메뉴

기능

Make Application Archive

Make Bootstrap, Make File Archive, Make Theme Archive 기능을 애플리케이션 아카이브 마법사를 사용해 한번에 수행합니다.

Make Bootstrap

앱을 구동시키는 부트스트랩 아카이브 파일을 생성합니다.

  • Run.zip

  • start_android.json

  • start_ios.json

Make File Archive

프로젝트 파일을 묶어서 프로젝트 아카이브 파일을 생성합니다.

  • [아카이브 아이템 이름].xzip

Make Theme Archive

테마 아카이브 파일을 생성합니다.

  • [테마 이름].zip

Package Builder

넥사크로플랫폼 애플리케이션을 iOS/안드로이드 플랫폼용 설치 파일로 만들고 다운로드 링크를 제공합니다.

9.3.8Debug

표 9-17Bookmark Bar

메뉴

기능

Window

선택한 디버그 기능 창을 활성화합니다.

Start Debugging

프로젝트 디버깅 모드 시작 <F5>

Start Form Debugging

현재 선택된 Form의 디버깅 모드 시작 <F6>

Stop Debuggin

디버깅 모드 종료

Restart

디버깅 모드 재시작

Step Into

한 스탭씩 디버그 작업 진행

다른 함수 호출 시 해당 함수로



이동 <F11>

Step Over

현재 함수의 나머지 부분을 실행하고, 함수 호출이 이루어진



다음 문장에서 멈춤 <F10>

Step Out

한 스탭씩 디버그 작업 진행

현재 스탭을 모두 실행하고, 다음 스탭으로 이동 <Shift+F11>

Run to Cursor

현재 커서가 위치한 줄까지 실행 후 멈춤

Toggle Breakpoint

브레이크 포인트를 설정/해제하는 기능 <F9>

Delete Selected Breakpoint

브레이크 포인트 목록 창을 활성화하고 선택된 브레이크 포인트를 제거

Delete All



Breakpoints

설정된 모든 브레이크 포인트를 제거

Go To Source

브레이크 포인트 목록 창을 활성화하고 선택된 브레이크 포인트의 소스 코드 위치로 이동

Enable/Disable Selected Breakpoints

브레이크 포인트 목록 창을 활성화하고 선택된 모든 브레이크 포인트를 활성화/비활성화하는 기능

Enable/Disable All Breakpoints

설정된 모든 브레이크 포인트를 활성화/비활성화하는 기능

9.3.9Tools메뉴바:Tools

그림 9-11Tools Menu

표 9-18Tools Menu

메뉴

기능

Options…

넥사크로 스튜디오의 Options 설정창 열기

External Tools

Options - External Tools항목에서 설정한 실행 프로그램 목록

9.3.10Window메뉴바:Window

그림 9-12Window Menu

표 9-19Window Menu

메뉴

기능

Cascade

편집중인 창을 계단식으로 배치

Tile

편집중인 창을 바둑판식으로 배치

Arrange Icons

최소화된 아이콘 정렬

Close

선택된 편집 창을 닫기

Close All But This

현재 열려있는 화면을 제외한 모든 화면 닫기

Close All

모든 편집 창을 닫기

Next

다음 편집 창으로 이동

Previous

이전 편집 창으로 이동

Maximize Active Window

미 구현된 기능

9.3.11Help메뉴바:Help

그림 9-13Help Menu

표 9-20Help Menu

메뉴

기능

Help

도움말 창 표시

About nexacro studio…

넥사크로 스튜디오 정보 창 표시

9.4단축키단축키

넥사크로플랫폼 애플리케이션 개발시 단축키를 사용하여 생산적인 면으로 봤을때 보다 더 빠르게 개발할 수 있습니다. 이페이지는 유용한 키보드 단축키에 대해서 설명합니다 .

적용범위

기능명

단축키

기능설명

공통

New

Ctrl + N

새로운 Form을 생성한다.

Open

Ctrl + O

이전에 생성한 파일을 연다.

Save

Ctrl + S

파일에서 수정한 내용을 저장한다.

Copy

Ctrl + C,

Ctrl + Ins

선택된 내용을 Clipboard에 복사한다.

Cut

Ctrl + X,

Shift + Del

선택된 내용을 잘라내어 Clipboard에 복사한다.

Paste

Ctrl + V,

Shift + Ins

Clipboard의 내용을 붙여넣는다.

Delete

Del

선택된 내용을 삭제한다.

Undo

Ctrl + Z,

Alt + Back

바로 이전 작업상태로 되돌린다.

Redo

Ctrl + Y

바로 전에 작업한 내용을 반복한다.

Find in Files

Ctrl+Shift+F

지정경로의 파일들 중 지정단어를 포함한 파일 찾기

Help

F1

넥사크로플랫폼 도움말(레퍼런스 가이드)이 나타난다.

Launch Project

Ctrl + F5

현재 열려있는 프로젝트를 실행한다.

적용범위

기능명

단축키

기능설명

Window

Next Window

Ctrl + Tab

열려있는 다음 파일을 활성화 한다.

Previous Window

Ctrl + Shift + Tab

열려있는 이전 파일을 활성화 한다.

적용범위

기능명

단축키

기능설명

Project Explorer

Edit

Ctrl + E

Project Explorer에서 선택된 Item을 편집한다.

Rename

F2

Project Explorer에서 선택된 Item의 이름을 변경한다.

Search

F3

입력된 Filter Keyword를 포함한 Item을 선택한다.

적용범위

기능명

단축키

기능설명

Properties Window

Show Items

Ctrl + F4

선택된 Property의 값이 Combo로 표시된다면, Combo의 내용을 펼쳐서 표시한다.

적용범위

기능명

단축키

기능설명

Form Design

Esape

Esc

현재 작업을 취소한다. (현재 작업이 없다면 선택된 컴포넌트의 상위 컴포넌트를 선택한다.)

Next

Tab

선택된 컴포넌트의 다음 Tab Order의 컴포넌트를 선택한다.

Previous

Shift + Tab

선택된 컴포넌트의 이전 Tab Order의 컴포넌트를 선택한다.

Move

방향키 ↑,↓,←,→

선택된 컴포넌트를 상,하,좌,우로 이동한다.

Move(minutely)

Ctrl + 방향키

↑,↓,←,→

선택된 컴포넌트를 상,하,좌,우로 미세하게 이동한다.

Resize

Shift + 방향키

↑,↓,←,→

선택된 컴포넌트의 사이즈를 변경한다.

Resize(minutely)

Ctrl + Shift + 방향키 ↑,↓,←,→

선택된 컴포넌트의 사이즈를 미세하게 변경한다.

InplaceEdit

F2

선택된 컴포넌트의 Text를 변경할 수 있는 InplaceEdit를 활성화 한다.

Select All

Ctrl + A

전체 컴포넌트들을 선택한다.

Tab Order

Ctrl + D

TabOrder 기능을 활성화 한다.

Transform

Ctrl + T

Transform 기능을 활성화 한다

Show Bind State

Ctrl + B

컴포넌트들의 Bind 정보를 표시한다.

Quick View

Ctrl + F6

현재 Form을 실행한다

적용범위

기능명

단축키

기능설명

Source Script

Find

Ctrl + F

특정 키워드를 찾는 Find Dialog 기능을 활성화 한다.

Find Next

F3

현재 커서 위치에서 Find 기능으로 찾은 키워드의 다음 위치를 찾는다.

Find Previous

Shift + F3

현재 커서 위치에서 Find 기능으로 찾은 키워드의 이전 위치를 찾는다.

Find Word

Ctrl + F3

현재 커서 위치에서 선택된 키워드와 동일한 문자열의 다음 위치를 찾는다.

Goto Line

Ctrl + G

입력된 라인으로 이동한다.

Match Brace

Ctrl + ]

현재 선택된 Brace에 매치되는 Brace로 커서가 이동된다.

Match Brace(selet)

Ctrl + Shift + ]

현재 선택된 Brace에 매치되는 Brace로 커서가 이동하면서 이동영역을 모두 선택한다

Replace

Ctrl + R

특정 키워드를 다른 키워드로 변경하는 Find and Replace Dialog 기능을 활성화 한다.

Select All

Ctrl + A

현재 파일 내 모든 내용을 선택한다.

Block Comment

/

선택된 영역을 주석으로 변경한다.

Unblock Comment

Alt + /

선택된 영역의 주석을 해제한다.

Bookmark Toggle

Ctrl + F2

현재 파일 내 원하는 지점에 Bookmark를 설정/해제 한다.

Bookmark Clear

Ctrl + Shift + F2

현재 파일 내 설정한 모든 Bookmark를 제거한다.

Bookmark Next

F2

현재 파일 내 설정한 다음 Bookmark를 따라간다.

Bookmark Previous

Shift + F2

현재 파일 내 설정한 이전 Bookmark를 따라간다.

Expand Max View

Ctrl + Shift + Enter

모든 DialogBar( Project Explorer, Output등 )을 최소하고 현재 윈도우를 최대화 한다

Change Tab Next

Ctrl + Down

해당 탭 바로 다음 탭으로 이동한다. (Design/Source/Script)

Change Tab Previous

Ctrl + Up

해당 탭 바로 이전 탭으로 이동한다. (Design/Source/Script)

Delete Line

Ctrl + Shift + L

커서가 위치한 현재 라인을 삭제한다.

Delete Line (keep line)

Ctrl + Shift + Back

커서가 위치한 현재 라인의 내용을 삭제한다.

Delete Paragraph

Ctrl + Del

커서의 위치를 기준으로 단락 단위로 삭제한다.

Enter

Ctrl + Shift + J

Enter와 동일한 기능

Tab

Ctrl + Shift + I

Tab와 동일한 기능

Next Source/Script Window

Ctrl + Shift + F6

다음 Source/Script 창으로 이동한다.

Select Paragraph

Ctrl + Shift + \

현재 커서 위치에서 단어 기준으로 단락을 나누어서 아래로 문자열을 선택한다.

Change Font

Alt + =

Font를 변경한다.

Move Start Position of Line

Home

공백을 제외한 라인의 시작 위치로 커서를 이동시킨다.

Move Start Position of Line(include space)

Alt + Home

공백을 포함한 라인의 시작 위치로 커서를 이동시킨다.

Move End Position of Line

End

라인의 마지막 위치로 커서를 이동시킨다

Move Start Position of File

Ctrl + Home

현재 파일의 시작 위치로 커서를 이동시킨다.

Move End Position of File

Ctrl + End

현재 파일의 마지막 위치로 커서를 이동시킨다.

Paragraph Next

Ctrl + \

다음 단락 위치로 커서를 이동시킨다.

Paragraph Previous

Ctrl + /

이전 단락 위치로 커서를 이동시킨다.

Magnifier

Ctrl + -(num), +(num)

파일 내용을 확대하거나 축소해서 표시한다.

Script(Only)

View Memberlist

Ctrl + Space

Memeberlist를 보여줍니다.