12.툴바, 메뉴바, 단축키

Edit

넥사크로 모듈 디벨로퍼는 "베타" 버전입니다.

- "베타" 기간 동안 일부 제품 기능은 변경될 수 있습니다.

- 온라인 매뉴얼 URL은 변경될 수 있습니다.

- 가이드에서 사용한 샘플 코드는 아래 링크에서 내려받을 수 있습니다.

https://github.com/TOBESOFT-DOCS/SIMPLE_MODULE_PROJECT/archive/master.zip

https://github.com/TOBESOFT-DOCS/SIMPLE_MODULE_PROJECT

12.1Toolbar 기능

넥사크로 모듈 디벨로퍼에서 지원하는 다양한 기능을 툴바에서 바로 사용할 수 있도록 지원합니다.

12.1.1Standard

프로젝트 열기, 저장, 복사, 붙여넣기 등 기본 기능을 지원하는 툴바입니다.

표 12-1Standard Bar

메뉴

기능

Open Project

Project 열기

Open

넥사크로 모듈 디벨로퍼에서 편집 가능한 형식의 파일 열기

New

새로운 프로젝트를 생성하거나 컴포지트 컴포넌트를 추가

Save

현재 열린 문서 저장

Save All

현재 열린 모든 문서 저장

Cut

선택 영역을 잘라내어 클립보드에 저장

Copy

선택 영역을 복사해서 클립보드에 저장

Paste

클립보드에 저장된 내용 붙여넣기

Options

옵션창 표시

About

제품 정보 및 라이선스 입력

12.1.2Align

화면 개발 시 컴포넌트 정렬 및 배치 기능을 지원하는 툴바입니다.

표 12-2Align Bar

메뉴

기능

Align Lefts

마지막에 선택된 Component의 Left 값을 기준으로 정렬

Align Centers

마지막에 선택된 Component의 수평 Center 값을 기준으로 정렬

Align Rights

마지막에 선택된 Component의 Right 값을 기준으로 정렬

Align Tops

마지막에 선택된 Component의 Top 값을 기준으로 정렬

Align Middles

마지막에 선택된 Component의 수직 Center 값을 기준으로

정렬

Align Bottoms

마지막에 선택된 Component의 Bottom 값을 기준으로 정렬

Same Width

마지막에 선택된 Component의 Width 값을 기준으로 너비를 맞춤

Same Height

마지막에 선택된 Component의 Height 값을 기준으로 높이를 맞춤

Same Size

마지막에 선택된 Component의 Size를 기준으로 크기 맞춤

Distribute Horizontally

Component 사이를 같은 수평 간격으로 분배 배치.

처음과 끝 Component 사이의 공간을 수평으로 분배하여 균등한 간격으로 Component를 재배치합니다.

Distribute Vertically

Component 사이를 같은 수직 간격으로 분배 배치.

처음과 끝 Component 사이의 공간을 수직으로 분배하여 균등한 간격으로 Component를 재배치합니다.

Distribute Horizontally by Specified Value

Component 사이를 같은 수평 간격으로 정렬 배치.

사용자가 직접 Dialog를 통해 Component의 간격을 조절할 수 있습니다.

Distribute Vertically by Specified Value

Component 사이를 같은 수직 간격으로 정렬 배치.

사용자가 직접 Dialog를 통해 Component의 간격을 조절할 수 있습니다.

Position Center

선택된 Component들을 Form Canvas의 수평 Center로 이동

Position Middle

선택된 Component들을 Form Canvas의 수직 Center로 이동

Position Left

선택된 Component들을 Form Canvas의 Left로 이동

Position Right

선택된 Component들을 Form Canvas의 Right로 이동

Position Top

선택된 Component들을 Form Canvas의 Top으로 이동

Position Bottom

선택된 Component들을 Form Canvas의 Bottom으로 이동


Fit to Contents

선택된 Component들을 컨텐츠와 min, max 속성값에 맞게 크기를 조정합니다.

Bring to Front

선택된 Component를 맨 앞으로 가져오기

Send to Back

선택된 Component를 맨 뒤로 보내기

Bring Forward

선택된 Component를 앞으로 가져오기

Send Backward

선택된 Component를 뒤로 보내기

Arrange to Tab Order

Tab Order 속성값에 따라 Source 코드 내 컴포넌트의 순서를 수정합니다.

Lock Components

Component의 위치를 마우스로 이동하지 못하도록 고정하거나 해제

12.1.3Bookmark

편집 중에 특정 줄로 쉽게 이동할 수 있는 Bookmark 기능을 지원하는 툴바입니다.

그림 12-1Bookmark Bar

표 12-3Bookmark Bar

메뉴

기능

Toggle Bookmark

현재 커서 위치에 Bookmark를 설정 및 삭제

Previous Bookmark

이전 Bookmark를 찾아 커서를 위치

Next Bookmark

다음 Bookmark를 찾아 커서를 위치

Delete All Bookmarks

설정된 Bookmark를 모두 삭제

Previous Bookmark in Document

현재 편집 창에서 이전 Bookmark를 찾아 커서를 위치

Next Bookmark in Document

현재 편집 창에서 다음 Bookmark를 찾아 커서를 위치

Delete All Bookmarks in Document

현재 편집 창에서 설정된 Bookmark를 모두 삭제

Go to Bookmark

선택한 북마크를 찾아 커서를 위치

Enable/Disable Bookmark

선택한 북마크를 탐색 대상에 포함/제외

Enable/Disable All Bookmarks

모든 북마크를 탐색 대상에 포함/제외

12.1.4Build

프로젝트 또는 파일을 자바스크립트 파일로 변환하거나 에뮬레이터 실행 기능을 지원하는 퉅바입니다.

메뉴

기능

Generate Module

프로젝트 전체를 자바스크립트 파일로 변환합니다. 변환된 파일은 옵션에서 지정된 폴더에 저장됩니다.

Generate File

편집 중인 파일을 자바스크립트 파일로 변환합니다.

Stop Generate

진행 중인 변환 작업을 중지합니다.

Emulate

선택한 오브젝트를 에뮬레이터에서 실행합니다.

12.1.5Component

ModuleDefinition에 등록된 오브젝트를 선택하고 화면에 배치하거나 등록하는 기능을 지원하는 툴바입니다.

Component 툴바에 표시되는 항목은 ModuleDefinition Objects 목록에 등록된 컴포넌트에 따라 다르게 보일 수 있습니다.

컴포넌트 선택, 이동

표 12-4컴포넌트

아이콘

이름

설명

Select

하나 이상의 컴포넌트를 마우스로 드래그해서 선택합니다.

Move

Form 디자인 편집 모드에서 화면이 그려지는 캔버스 영역의 위치를 이동합니다.

기본 컴포넌트

표 12-5컴포넌트

아이콘

이름

설명

Button

사용자로부터 마우스 입력을 받을 때 사용하는 컴포넌트

Calendar

날짜를 입력할 때 사용되는 컴포넌트

CheckBox

Check 표시에 대한 TRUE/FALSE 값을 가지는 컴포넌트

Combo

Edit와 Drop down List를 통합한 형태의 컴포넌트

Dataset

데이터를 테이블 형태로 저장하는 컴포넌트

Div

Form 안에 다른 Form을 불러와서 하나의 Form인 것처럼 사용하거나, 관련 있는 컴포넌트들을 하나의 그룹으로 묶어서 처리할 경우 사용되는 컴포넌트

Edit

문자열의 입출력을 가지는 컴포넌트

Grid

스프레드시트와 유사하게 Dataset의 내용을 표 형식으로 처리하는 컴포넌트

GroupBox

화면을 구성할 때 관련 있는 컴포넌트들을 그룹화하는 컴포넌트

ImageViewer

화면에 이미지를 표시할 때 사용되는 컴포넌트

ListBox

항목을 목록으로 나열한 후 선택할 경우 사용되는 컴포넌트.

MaskEdit

날짜의 연월일시(yyyy/mm/dd hh:mi:ss) 형식 또는 숫자의 콤마 표시와 같이 규정된 형식으로 문자열의 입출력을 가지는 컴포넌트

Menu

Menu 아이템을 구성할 경우 사용되는 컴포넌트

Plugin

Plugin을 사용할 경우 사용되는 컴포넌트

PopupDiv

하나의 화면에 여러 개의 부분화면을 구성할 때 사용

PopupMenu

PopupMenu를 구성할 경우 사용되는 컴포넌트

ProgressBar

작업의 현재 진행 상태를 그래픽을 이용하여 보여주는 컴포넌트

Radio

제시된 여러 가지 선택사항 중에서 하나의 항목을 선택해야 할 때 사용하는 컴포넌트

Spin

정해진 규칙에 따라 손쉽게 숫자를 입력받을 때 사용하는 컴포넌트

Static

고정된 텍스트를 표시할 때 사용되는 컴포넌트

Tab

한 화면에서 여러 개의 Tab page를 나눌 경우 사용되는 컴포넌트

TextArea

여러 줄의 문자열의 입출력을 가지는 컴포넌트

12.1.6Position

컴포넌트의 Text, Tooltip, Position 속성값 편집을 지원하는 툴바입니다.

메뉴

기능

ID

컴포넌트의 id 속성값 선택

Text

컴포넌트의 text 속성값 입력

Tooltip

컴포넌트의 tooltiptext 속성값 입력

Left (L)

컴포넌트의 left 속성값 입력

Top (T)

컴포넌트의 top 속성값 입력

Width (W)

컴포넌트의 width 속성값 입력

Height (H)

컴포넌트의 height 속성값 입력

Right (R)

컴포넌트의 right 속성값 입력

Bottom (B)

컴포넌트의 bottom 속성값 입력

Position Editor

컴포넌트의 Position Editor 실행

Position Units

컴포넌트를 선택하지 않은 경우 Position Unit 기본 설정 변경

Edit 컴포넌트의 text 속성처럼 컴포넌트의 속성이 ReadOnly인 경우에는 해당 항목이 비활성화됩니다.

12.2Menu Bar

넥사크로 모듈 디벨로퍼에서 제공하는 기본 기능을 선택하고 실행할 수 있습니다.

12.2.1File

표 12-6File Menu

메뉴

기능

New


• Project - 새로운 프로젝트 생성

• Composite Component - 새로운 컴포지트 컴포넌트 생성

• User Folder - 새로운 폴더 생성

Open


• Project - 모듈 프로젝트 새로 열기

• File - 내용 확인 필요

Close

현재 열린 창 닫기

Close Project

현재 열린 프로젝트 닫기

Save

현재 활성화된 편집 화면을 저장하기

Save As

현재 활성화된 편집 화면을 다른 이름으로 저장하기

Save All

현재 열린 모든 편집 화면 및 Project Explorer에서 변경된 모든 내용을 저장하기

Install Module

모듈 프로젝트에서 생성한 모듈 파일을 설치

Recent Files

최근 열었던 파일 목록을 표시

Recent Projects

최근 열었던 프로젝트 목록을 표시

Exit

넥사크로 모듈 디벨로퍼 종료

12.2.2Edit

표 12-7Edit Menu

메뉴

기능

Add

오브젝트를 선택하고 속성, 메소드, 이벤트 항목을 추가

Undo

이전 상태로 되돌림

Redo

Undo 실행 이전 상태로 되돌림

Cut

선택된 영역을 잘라서 클립보드에 복사

Copy

선택된 영역을 클립보드에 복사

Copy ID

선택한 컴포넌트의 ID값을 클립보드에 복사

(디자인모드에서 하나의 컴포넌트 선택 시에만 활성화됩니다)

Paste

클립보드에 있는 내용을 붙여넣기

Paste Special

클립보드에 있는 컴포넌트의 Property 및 Bind정보를 사용자가 선택하여 붙여넣기

Delete

선택된 컴포넌트나 선택된 영역의 텍스트 삭제

Select All

Script 창에서 모든 텍스트 선택

Find…

Script 창에서 문자열 찾기

Find in File…

지정경로의 파일 중 지정단어를 포함한 파일 찾기

Replace

Script창에서 특정 문자열을 다른 문자열로 교체

Goto Line…

Script창에서 특정 라인으로 커서 이동

Bookmark

Bookmark메뉴에서 제공하는 기능은 Toolbar[Bookmark Bar]의 기능과 동일.

Comment

Selection

Script창에서 선택된 영역의 문자열을 주석처리

UnComment

Selection

Script창에서 선택된 영역의 문자열 주석해제

Refresh

파일을 Reload

12.2.3Assist

표 12-8View Menu

메뉴

기능

Show Thumbnail

Form 또는 이미지 선택 시 활성화되며 선택한 항목에 대한 미리보기 이미지 제공

Copy Full Path

선택된 파일이 저장된 경로를 클립보드에 복사

Open Containing Folder

선택된 파일 또는 폴더 위치를 윈도우 탐색기를 열어서 보여줍니다

Open File in Project

프로젝트 내 포함된 파일을 검색하고 직접 실행할 수 있습니다.

Code Snippet

Code Snippet Editor를 실행합니다.

12.2.4View

표 12-9View Menu

메뉴

기능

Toolbars


• Standard - Standard Bar를 표시/숨김

• Bookmark - Bookmark Bar를 표시/숨김

• Align - Align Bar를 표시/숨김

• Build - Build Bar를 표시/숨김

• Component - Component Bar를 표시/숨김

• Position - Position Bar를 표시/숨김

Statusbar

Statusbar를 표시/숨김

Project

Explorer

Project Explorer창을 표시합니다. Project Explorer창이 열려있을 때는

focus만 이동합니다.

Resource Explorer

프로젝트에 포함된 리소스 항목을 표시합니다.

Properties

속성창을 표시합니다. 속성창이 열려있을 때는 focus만 이동합니다.

Computed Style

속성창에 Computed Style 탭을 표시합니다.

Bookmarks

Bookmarks창을 표시합니다.

Dataset Editor

Dataset Editor창을 표시합니다.

Output


• Output - Output창을 표시

• Error List - Error List창을 표시

• Find Result 1,2,3 - Find Result 1,2,3 창을 표시

• Reference - Reference창을 표시

12.2.5Design

표 12-10Design Menu

메뉴

기능

Align

Space

Size

Position

Fit to Contents

선택된 Component들을 컨텐츠와 min, max 속성값에 맞게 크기를 조정합니다.

Arrange

Arrange to Tab Order

Tab Order 속성값에 따라 Source 코드 내 컴포넌트의 순서를 수정합니다.

Lock Components

Component의 위치를 마우스로 이동하지 못하도록 고정하거나 해제

Zoom


현재 열려있는 화면의 확대/축소 비율 설정

Hotkey List

hotkey 속성값이 지정된 컴포넌트 목록을 편집합니다.

Tab Order Editor (View Type)

컴포넌트의 Tab Order를 수정할 수 있는 편집모드를 시작합니다.

Tab Order Editor (List Type)

컴포넌트의 Tab Order 목록을 표시하고 순서를 변경할 수 있는 창을 띄웁니다.

State View

Tab Order: Form Design화면에 컴포넌트의 Tab Order를 표시합니다

Bind: 컴포넌트의 Bind 상태를 표시합니다.

Position Editor

컴포넌트의 Position Editor 실행

Position Units

컴포넌트를 선택하지 않은 경우 Position Unit 기본 설정 변경

Show Invisible Object Area

Invisible Object 창을 감춘 경우에 해당 창이 보이도록 합니다.

Show Binding Components List

Binding Components List 창을 감춘 경우에 해당 창이 보이도록 합니다.

Align, Space, Size, Position, Arrange 관련 기능은 툴바에서 제공하는 기능과 같습니다.

Toolbar 기능 > Align 설명을 참고하세요.

12.2.6Layout

표 12-11Dataset Editor

메뉴

기능

Add Layout

레이아웃 추가

Copy & Add Layout

선택한 레이아웃 정보를 복사해 새로운 레이아웃을 추가

Delete Layout

선택한 레이아웃 삭제

Rename Layout

선택한 레이아웃의 이름을 변경

Add Step

스탭 추가

Delete Step

스탭 삭제

Easy Design Mode

View 컴포넌트를 포함한 Form을 편집하는 경우 Easy Design Mode 활성화 여부 선택

12.2.7Generate

메뉴

기능

Module

프로젝트 전체를 자바스크립트 파일로 변환합니다. 변환된 파일은 옵션에서 지정된 폴더에 저장됩니다.

File

편집 중인 파일을 자바스크립트 파일로 변환합니다.

Stop Generate

진행 중인 변환 작업을 중지합니다.

Emulate

선택한 오브젝트를 에뮬레이터에서 실행합니다.

12.2.8Deploy

메뉴

기능

Module Dependency

2개 이상의 오브젝트를 추가한 경우 배포 파일에서 오브젝트 추가 순서를 설정합니다.

Module Package

프로젝트를 배포할 수 있는 형태로 압축해 xmodule 파일을 생성합니다.

Module Package Customzie

모듈 배포 시 JSON 구성을 변경하고 xmodule 파일을 생성합니다.

프로젝트가 열려있지 않은 경우에도 실행할 수 있습니다.

12.2.9Tools

표 12-12Tools Menu

메뉴

기능

Options

Options 설정창 열기

12.2.10Window

표 12-13Window Menu

메뉴

기능

Cascade

편집 중인 창을 계단식으로 배치

Tile

편집 중인 창을 바둑판식으로 배치

Arrange Icons

최소화된 아이콘 정렬

Close

선택된 편집 창을 닫기

Close All But This

현재 열려있는 화면을 제외한 모든 화면 닫기

Close All

모든 편집 창을 닫기

Next

다음 편집 창으로 이동

Previous

이전 편집 창으로 이동

Maximize

편집 창을 최대화

12.2.11Help

표 12-14Help Menu

메뉴

기능

Help

도움말 창을 표시합니다.

Chart 컴포넌트처럼 추가 모듈을 설치한 경우 추가된 모듈 도움말을 선택할 수 있습니다.


Online Manual

온라인 매뉴얼을 웹브라우저에서 실행합니다.

http://docs.tobesoft.com/nexacro_17_ko

About nexacro module developer

넥사크로 모듈 디벨로퍼 정보 창 표시