9.도움말 만들기

Edit

넥사크로 모듈 디벨로퍼는 "베타" 버전입니다.

- "베타" 기간 동안 일부 제품 기능은 변경될 수 있습니다.

- 온라인 매뉴얼 URL은 변경될 수 있습니다.

- 가이드에서 사용한 샘플 코드는 아래 링크에서 내려받을 수 있습니다.

https://github.com/TOBESOFT-DOCS/SIMPLE_MODULE_PROJECT/archive/master.zip

https://github.com/TOBESOFT-DOCS/SIMPLE_MODULE_PROJECT

모듈 프로젝트를 배포할 때 사용자가 참고할 수 있는 도움말을 같이 배포할 수 있습니다. 컴포넌트에 대한 기본 설명과 속성, 메소드, 이벤트의 사용법을 안내할 수 있습니다.

현재 버전에서는 CHM(Compiled HTML) 파일 형태의 도움말만 지원합니다. 이번 장에서는 간단하게 CHM 파일 형태의 도움말을 생성하고 배포하는 방법을 살펴봅니다.

9.1HTML Help Workshop 설치하기

CHM 파일을 생성할 수 있는 도구는 여러 가지가 있습니다. 그 중에서 HTML Help Workshop은 무료로 제공되고, 간단하게 CHM 파일을 생성할 수 있습니다.

1

아래 링크에 접속합니다.

2

[Download] 버튼을 클릭하면 보이는 파일 목록에서 "htmlhelp.exe" 파일을 선택하고 [Next] 버튼을 클릭합니다.

3

htmlhelp.exe 파일을 내려받습니다.

4

내려받은 htmlhelp.exe 파일을 실행해 HTML Help Workshop을 설치합니다.

5

앱 목록에서 HTML Help Workshop을 확인하고 실행합니다.

9.2간단한 CHM 파일 만들기

CHM 파일에는 목차, 인덱스 등의 여러 가지를 설정할 수 있지만, 이번 예제에서는 하나의 페이지만을 가지는 CHM 파일을 생성합니다.

1

프로젝트를 생성할 위치에 먼저 HTML 파일을 생성합니다.

HTML 파일은 PRE 태그를 사용해 간단하게 구성하고 Help.htm 이라는 이름으로 저장합니다.

<html>
<body>
<pre>
SIMPLE MODULE
- TwoMonthCalendar
</pre>
</body>

2

HTML Help Workshop을 실행합니다.

3

메뉴 [File > New] 항목을 선택하고 생성할 유형은 [Project]를 선택합니다.

4

생성 마법사에서 다른 것은 체크하지 않고 프로젝트 파일 경로만 지정합니다.

프로젝트가 생성되면 Project 탭에 기본 정보가 표시됩니다.

5

Contents 탭을 선택하고 콘텐츠를 추가합니다.

Contents 탭을 선택하면 hhc 파일을 새로 만들것인지 물어봅니다. [Create a new contents file] 항목이 선택된 상태에서 [OK] 버튼을 클릭합니다.

6

오른쪽 툴바에서 [insert a page] 항목을 선택합니다.

7

Entry title 항목에 "SIMPLE MODULE"을 입력하고 [Add] 버튼을 클릭하면 파일을 선택할 수 있는 창이 표시됩니다. [Browse] 버튼을 클릭하고 앞에서 만든 Help.htm 파일을 선택합니다.

8

Contents 탭에 추가한 페이지 목록이 표시되는 것을 확인합니다.

9

Project 탭을 선택하고 오른쪽 툴바에서 [Change project options] 항목을 선택합니다.

10

Options 창에서 Title 항목을 입력하고 Default file 항목에 Help.htm 파일을 입력합니다.

11

메뉴 [File > Compile] 항목을 선택하면 CHM 파일을 생성합니다.

CHM 파일 생성 시 지정한 파일이 없는 경우 에러 메시지를 출력합니다.

12

생성된 CHM 파일을 실행해 정상적으로 콘텐츠가 표시되는지 확인합니다.

9.3모듈 프로젝트에 도움말 추가하기

1

Project Explorer 탭에서 Help 항목 아래에 언어(ENG, JPN, KOR) 폴더를 선택하고 컨텍스트 메뉴에서 [Import Help Files] 항목을 선택합니다.

2

CHM 파일을 선택해 추가합니다. 선택한 언어 폴더에 맞는 CHM 파일을 추가할 수 있습니다.

CHM 파일은 운영체제에서 설정한 언어에 따라 일본어, 한국어인 경우에는 해당 폴더 아래에 있는 CHM 파일을 실행하고 나머지 언어는 ENG 폴더 아래에 있는 파일을 실행합니다.

3

넥사크로 스튜디오에서 모듈을 설치합니다. 메뉴 [Help > Help] 항목에서 추가된 도움말을 확인할 수 있습니다.

4

Form 화면에 컴포지트 컴포넌트를 배치한 후 컴포넌트를 선택하고 F1 단축키 입력 시 모듈 도움말이 실행됩니다.