1.넥사크로 스튜디오 설치

1.1넥사크로 스튜디오 설치

넥사크로 스튜디오는 넥사크로플랫폼 설치 패키지에 포함되어 배포됩니다. 배포된 Setup 파일(nexacro17_SetupStudio.exe)을 실행하면 설치 과정이 진행됩니다.

Windows Vista 이상의 운영 체제는 보안경고창이 나타날 수 있습니다. 반드시 ‘실행’을 선택해 주시기 바랍니다.

바탕화면에 단축 아이콘을 만들고자 한다면 [created on the desktop] 항목을 체크합니다. 64비트 운영체제를 사용하고 있다면 64비트를 지원하는 NRE를 설치할 수 있습니다. 64비트 NRE를 설치하려면 [NRE (x64)] 항목을 체크합니다.

그림 1-1프로그램 설치 시작

[Finish] 버튼을 클릭하여 프로그램 설치를 완료합니다.

그림 1-2프로그램 설치 완료

1.2설치 파일

넥사크로 스튜디오를 설치한 폴더 내 생성되는 주요 파일과 폴더는 아래와 같습니다.

폴더명

설명

help

- 넥사크로플랫폼 도움말 폴더

컴파일된 HTML 도움말 파일(compiled html help, CHM)로 제공합니다.

넥사크로 스튜디오는 운영체제 언어 설정에 따라 해당하는 한국어, 영어 도움말 파일을 실행합니다.

nexacro17lib

- 넥사크로플랫폼 라이브러리 폴더

설치된 버전의 라이브러리 파일이 포함된 폴더입니다.

metainfo 파일을 포함하고 있습니다. metainfo 파일은 넥사크로 스튜디오에서만 사용하는 파일이며 배포 대상은 아닙니다.

license

- 라이선스 관련 문서 폴더

제품 라이선스, 오픈소스 라이선스 관련 문서 파일이 포함된 폴더입니다.

theme

- 테마 폴더

넥사크로 스튜디오 테마, 운영체제별 기본 테마 파일이 포함된 폴더입니다.

Embedded

- 넥사크로 스튜디오 내에서 사용하는 넥사크로플랫폼 앱

그리드 콘텐츠 에디터나 에뮬레이터처럼 넥사크로플랫폼을 사용해 만든 기능 관련 소스 코드가 저장된 폴더입니다.

SetupRuntime

빌드 시 참조할 운영체제별 모듈 파일이 포함된 폴더입니다.

파일명

설명

nexacro.exe

- NRE 실행 파일

nexacrodeploy17.exe

- 프로젝트 제너레이트, 난독화 실행 파일

nexacromigrator17.exe

- 이전 버전 프로젝트 마이그레이션 실행 파일

ResourceUpdater_x64.exe

ResourceUpdater_x86.exe

- NRE 배포 파일 생성 실행 파일

nexacroemulator17.exe

- 에뮬레이터 실행 파일

nexacrostudio17.exe

- 넥사크로 스튜디오 실행 파일

unins000.exe

- 넥사크로 스튜디오 삭제 실행 파일

제어판에서 해당 프로그램을 찾아 삭제할 수도 있습니다.

nexacromoduledeveloper17.exe

- 넥사크로 모듈 디벨로퍼 베타 실행 파일

caddy.exe

- 로컬 웹 서버 실행 파일

설치하는 제품 버전에 따라 설치된 파일 목록이 일부 변경될 수 있습니다.

1.3버전 확인

넥사크로 스튜디오의 메뉴[Help > About nexacro studio]를 선택하면 설치된 넥사크로 스튜디오의 버전과 등록된 라이선스 정보를 확인할 수 있습니다.

1.4실행 환경 설정

넥사크로 스튜디오를 처음 설치하면 60일 동안 사용할 수 있는 체험판으로 설정됩니다. 최초 실행 시 경고 팝업 창이 표시되는데 [OK] 버튼을 클릭하면 다음 단계로 진행할 수 있습니다. 제품을 구매한 경우에는 발급받은 Product Key를 입력해 사용할 수 있습니다.

넥사크로 스튜디오 실행 환경을 설정합니다. Perspective, Command Type, Theme를 설정할 수 있습니다. 설정한 항목은 메뉴[Options > Environment > General > Development Tools]에서 변경할 수 있습니다.

1.5라이선스 인증

넥사크로 스튜디오의 메뉴[Help > About nexacro studio]를 클릭하고 버전 확인창에서 'Enter New License' 버튼을 클릭합니다. 라이선스 입력 창에는 'Application/Service Name'과 'Developer License Key' 2개 항목을 입력합니다.

정상적인 값이 입력되었다면 아래와 같은 메시지가 뜨면서 라이선스 인증을 처리합니다.

잘못된 값을 입력하거나 이미 인증된 코드를 입력하면 아래와 같은 메시지가 뜨면서 라이선스 인증이 처리되지 않습니다.