4.X-UP 빌더 구성

Edit

이 장에서는 X-UP 빌더를 구성하는 메뉴와 기본적인 기능에 관해 설명합니다.

아래 그림은 X-UP 빌더를 구성하는 요소에 대한 설명입니다.


구성요소

설명

1

메뉴바

이클립스 기본 메뉴 항목과 X-UP 모델 개발을 위한 메뉴 항목을 제공합니다.

2

개발도구 툴바

자주 사용되는 메뉴들을 아이콘 형식으로 모아놓은 곳이며, 이클립스 기본 항목과 X-UP 모델 개발을 위한 항목이 제공됩니다.

3

X-UP Explorer

활성화된 프로젝트의 내용이 트리 형식으로 보이고, X-UP 프로젝트만의 필터링 기능을 제공합니다.

4

Outline View

현재 활성화된 에디터에 연계되어 관련정보를 트리형태로 구성합니다.

Domain Editor : 도메인 에디터의 각탭에서 정의된 모든 속성정보를 모아서 간략한 트리 형태로 구성합니다.

X-UP Editor : 모델 에디터에서 정의된 모든 노드들을 트리로 구성하고, 전체 화면의 축소한 Scrollable Thumbnail 화면을 출력합니다.

5

Content Pane

선택된 프로젝트 또는 활성화된 파일의 작업공간으로 주로 해당 파일과 연결된 에디터가 위치합니다.

X-UP 빌더에는 Domain Editor, Gathering Editor, Transaction Editor, Automation Editor 및 Java Editor 가 위치하게 됩니다.

6

Editor View

X-UP 빌더 에서 제공되는 모든 뷰들이 위치합니다. View Layout은 Top, Bottom 2곳에서 나누어 위치하게 됩니다

모델 에디터와 연결된 뷰들이 위치하게 됩니다.

Editor Info Views, Function View, Result DataSet View, Properties View, 기타 Eclipse Views

7

Editor Palette

모델 에디터에서 모델 개발시 필요한 컴포넌트 그룹입니다. 드로잉 기본 메뉴, Output DataSet 및 Function 컴포넌트로 구성되어있습니다.

8

X-UP DataSource View

프로젝트에 정의된 모든 데이터소스 정보를 조회하고 출력할 수 있습니다. 또한 모델 개발시 드래그 앤 드롭으로 쉽게 필요한 컴포넌트를 직관적으로 생성할 수 있습니다.

4.1메뉴바 / 개발도구 툴바

메뉴바는 이클립스 기본 메뉴에 X-UP 빌더 메뉴가 추가된 형태로 구성되어 있습니다. 이클립스에서 자주 사용되는 공통 메뉴는 다음과 같습니다.

메뉴명

아이콘

설명

New

File > New

새로운 프로젝트 또는 파일을 생성합니다.

Open


File > Open

기존 프로젝트나 파일을 오픈합니다.

Save

File > Save

저장합니다.

Print

File > Print

프린트합니다.

Eclipse Help

Help > Help Contents

도움말을 보여줍니다.

다음 메뉴들은 기본 기능 외 X-UP 빌더 기능이 추가된 메뉴들입니다.

X-UP 빌더는 X-UP 모델 개발을 위한 다양한 메뉴들을 제공합니다. 관련된 기능은 X-UP 빌더 내 다양한 곳에 있으며 주로 다음 몇 군데에서 찾아볼 수 있습니다.

·

.

항목

단축키

설명

create X-UP Project

Alt+1

새로운 X-UP 프로젝트를 생성합니다.

create Automation Model


새로운 Automation 모델을 생성합니다.

new X-UP DataSource

Alt+4

새로운 데이터소스를 생성합니다.

Create GlobalEvent


글로벌 이벤트를 생성합니다.

generate Remote Test Source

Ctrl+Shift+1

선택한 모델을 기반하여 Remote 테스트를 할 수 있는 테스트 클래스를 생성합니다.

generate Junit Test Class

Ctrl+Shift+3

선택한 모델을 테스트할 수 있는 간단한 JUnit Test Case를 생성합니다.

generate All Junit Test Class

Ctrl+Shift+2

선택한 프로젝트에 존재하는 모든 모델을 대상으로 JUnit Test Case를 생성합니다.

X-UP Log Masking


선택된 프로젝트에 정의되어 있는 Server URL들의 로그 암호화를 정의합니다.

X-UP License Manage


선택된 프로젝트에 정의되어 있는 Server URL들의 라이선스를 관리합니다.

Validate

Ctrl+Shift+6

모델에서 사용중인 다른 모델의 스키마 검증

Validate All

Ctrl+Shift+7

선택한 프로젝트에 존재하는 모든 모델을 대상으로 validate 기능 수행

4.2X-UP Explorer

X-UP Explorer는 X-UP 프로젝트 목록을 트리 형식으로 출력하고 필터링 기능을 제공합니다. 주요 기능은 아래와 같습니다.

4.2.1X-UP 프로젝트

X-UP 프로젝트의 기본 구조는 다음과 같은 형태로 되어있습니다.

현재 프로젝트 생성 시 존재하는 위의 폴더 및 파일 이름은 내부적으로 미리 약속된 이름으로 사용중이므로 다른 이름으로 변경하거나 삭제하면 안됩니다.

4.2.2X-UP 필터

일반 사용자를 위해 모델 개발 시에는 직접적으로 관련없는 모든 구성요소가 보이지 않도록 X-UP Explorer에서 필터링 기능을 사용할 수 있습니다.

필터링 설정은 X-UP Explorer내에 존재하는 모든 프로젝트에 영향을 미칩니다. 필터링 리스트에서 특정 항목에 체크를 한다는 것은 체크된 항목을 숨기겠다는 의미가 됩니다.

항목

설명

.* resource

Hides resources with names that start with a '.'

*BaseAutomationLogic.java

Hide *BaseAutomationLogic.java

*BaseTransactionLogic.java

Hide *BaseTransactionLogic.java

bin folder

Hide bin folder

Empty parent packages

Hides empty packages which do not contain Java files but other sub-folders

Libraries from external

Hides libraries from external

Libraries in project

Hides local libraries i.e. those contained inside the project itself

metadata folder

Hide *.metadata folder

Non X-UP Project

Hides all projects without XSB nature

Package declaration

Hide package declaration

  • BaseAutomationLogic.java 는 모델 개발시 에디터에 의해 자동으로 생성되는 파일입니다. 각 에디터에 의해 자동으로 생성되는 자바 소스코드를 확인하고자 한다면 필터의 체크박스를 선택 해제하시면 됩니다.


4.3X-UP 위자드(Wizard)

X-UP 빌더에서 제공하는 위자드는 아래와 같습니다.

4.3.1New X-UP 프로젝트 위자드(Project Wizard)

X-UP 프로젝트 위자드는 다양한 곳에서 시작할 수 있으나 주로 개발도구 툴바의 New X-UP 프로젝트 버튼( )을 사용합니다.

X-UP 프로젝트 위자드는 프로젝트 이름만 입력하는 간단한 화면으로 구성되어 있습니다. 프로젝트 이름을 입력하고 'Finish' 버튼을 클릭하면 해당 프로젝트 이름으로 프로젝트가 생성됩니다.

프로젝트 이름은 다양한 곳에서 사용되기 때문에 숫자로 시작하거나 이름 사이에 띄어쓰기나 특수기호를 지원하지 않습니다. X-UP 빌더에서 X-UP 프로젝트 생성 시 도메인 이름은 프로젝트 이름과 같은 이름으로 자동 결정되고 rename 기능을 통해 변경 가능합니다.

4.3.2New X-UP 데이터소스 위자드(DataSource Wizard)

New X-UP 데이터소스 위자드는 선택된 X-UP 프로젝트에서 X-UP 모델 개발 시 사용될 데이터소스를 생성합니다.

X-UP 빌더에서 데이터소스를 생성하는 방법은 다음과 같습니다.

나머지 데이터소스를 생성하는 방법은 선택된(작업 중인) X-UP 프로젝트의 mashup.msh에 등록되어 실제 X-UP 모델이 데이터를 가져올 때 사용됩니다.

정의할 수 있는 데이터 소스는 다음과 같습니다.

데이터소스

설명

OpenApi

Http Url로 접근하여 가져온 정형화된 데이터를 가공하고자 할 경우

DB

DataBase 데이터소스

X-UP

X-UP 데이터소스

SAP RFC

SAP RFC connection

Cobol

Visual Cobol 데이터소스

표의 WebService 삭제하였습니다.

X-UP 빌더 에서 X-UP 모델을 만들기 위해선 데이터소스 정보가 필요하나 모델을 만들 때마다 데이터소스를 정의해야 한다면 상당히 불편할 것입니다. 그래서 불필요한 반복작업을 최대한 줄이고 재사용 가능한 형태로 데이터소스를 정의하고 보관할 필요가 있습니다.

X-UP 빌더 에서 제공하는 모든 DataSource 정의화면에는 다음 기능이 공통으로 있습니다.

기능

설명

Test Connection

테스트

Import

자신의 PC에 저장된 datasource xml file 가져오기

Export

datasource 정보를 자신의 PC에 xml file 형태로 저장하기

Copy from

X-UP 빌더 Preference에 등록된 datasource 정보 가져오기(복사)

Add to

datasource 정보를 X-UP 빌더 Preference에 저장하기

예를 들어 'Copy from' 기능의 경우, X-UP 빌더는 환경설정 페이지인 [Window > Preferences… > X-UP > DataSource] 에서 데이터 소스를 정의했거나 Create DataSource Dialog 화면에서 'Add to' 버튼으로 Preference에 등록한 데이터소스가 존재한다면 이후에 같은 데이터소스를 생성할 때는 'Copy from' 기능을 이용하여 복사하여 빠르게 생성할 수 있습니다.

X-UP Preference 에 정의된 데이터소스 정보들은 참조 및 재사용을 위한 것일 뿐 모델 링크되는 개념은 아닙니다. 즉 특정 모델을 생성 시 데이터소스 정의 화면에서 Preference에 존재하는 데이터소스를 선택했다 하더라도 Copy 해서 생성하는 것이지 Link가 되는 것은 아닙니다.

4.3.3New X-UP 오토메이션 모델 위자드(Automation Model Wizard)

New X-UP 오토메이션 위자드는 오토메이션 모델을 만들기 위해 새롭게 추가된 위자드입니다.

오토메이션 모델은 직관적인 GUI 에디터를 제공하여 더욱 시각적인 언어로 비즈니스 서비스를 개발할 수 있습니다.

항목

설명

Model Name

오토메이션 모델의 이름을 입력합니다. 프로젝트 내에 중복되지 않는 이름을 등록하면 되며, 영어 이외의 다른 문자열은 허용되지 않습니다.

Description

모델의 간략한 설명을 입력합니다.

Charset

문자열 인코딩 타입을 정의합니다.

4.4X-UP 에디터(Editor)

4.4.1도메인 에디터(Domain Editor)

도메인 에디터는 mashup.msh 파일을 더블클릭하면 나오는 에디터로서 사용자명, 프로젝트 설명, 디플로이 경로, 데이터소스 정의, 모델그룹 정의 등을 합니다.

도메인 에디터는 2개의 탭으로 구성되어 있습니다.

Overview

Overview 페이지는 작성자명과 프로젝트 설명을 등록합니다.

항목

설명

Author

사용자 이름 (선택)

Description

설명 (선택)

DataSource

DataSource 페이지에서는 X-UP 모델 개발 시 사용되는 데이터 소스를 등록, 수정, 삭제, 복사 등의 일을 할 수 있습니다.

항목

설명

New

새로운 데이터소스를 생성합니다.

Edit

선택한 데이터소스를 수정합니다. (이름은 수정 불가)

Delete

선택한 데이터소스를 삭제합니다.

Copy as

선택한 데이터소스를 복사하여 다른 이름의 데이터 소스를 생성합니다.

Add to preference

선택한 데이터소스를 preference의 X-UP 데이터소스에 등록합니다.

사용 중인 데이터소스를 삭제하려고 하면 다음 경고 메시지가 출력됩니다.

만약 모델에서 사용 중인 데이터소스를 삭제하고자 한다면, 먼저 모델에서 다른 데이터소스로 변경한 후 삭제해야 합니다.

4.4.2오토메이션 모델 에디터(Automation Model Editor)

X-UP 오토메이션 모델(XAM)은 직관적인 비즈니스 서비스 개발이 가능한 X-UP 모델입니다. XAM은 직관적이며 사용자 소스 코딩을 최소화하고 드래그 앤 드롭만으로 쉽게 서비스를 개발할 수 있습니다.

Palette

Palette는 XAM 에디터에서 사용할 수 있는 기본적인 도구들을 가지고 있습니다.

현재 제공되는 항목은 다음과 같습니다.

Select는 디폴트로 선택되는 항목으로써 에디터의 노드들을 선택하거나 이동시킬 수 있습니다. Connect 모드에서 Select 모드로 변경하기 위해선 직접 Palette에서 Select를 선택하거나 에디터에서 바탕화면을 클릭하면 자동으로 Select 모드로 변경됩니다.

Connect는 노드들 간에 커넥션을 생성할 수 있습니다. 커넥션이 선택되어지면 select 모드로 변경되기 전까지 계속해서 커넥션을 생성할 수 있습니다. 커넥션 종류는 연결되는 노드의 타입에 따라 자동으로 결정됩니다.

기타 나머지 항목은 아래 상세 기능 정보에서 확인할 수 있습니다.

Drawing Pane

Drawing Pane은 실제 서비스를 디자인하기 위한 에디터입니다. 코딩을 최소화하고 드래그 앤 드롭 방식으로 직관적인 비즈니스 서비스를 구현할 수 있습니다.

처음 모델을 생성하면 Start와 End 노드만 존재합니다.

Start와 End는 서비스의 시작과 종료를 의미하며 자유롭게 원하는 컴포넌트를 드래그 앤 드롭하여 비즈니스 서비스를 구성할 수 있습니다. XAM 에디터는 기본적으로 컴포넌트와 커넥션의 조합으로 빠르고 쉽게 원하는 서비스를 구현할 수 있으며, 에디터에서 직접 사용자가 자바 코드를 등록하여 다른 컴포넌트와 함께 동작할 수도 있습니다.

XAM 에디터에는 아래의 타입의 커넥션이 존재합니다.

프로세스 커넥션

프로세스 커넥션은 하나의 서비스가 동작하기 위한 실행 순서를 나타냅니다.

시작부터 종료에 이르기까지 각 컴포넌트의 실행 순서를 나타내므로 직관적인 서비스를 구현해 가독성을 높입니다.

프로세스 커넥션이 연결되지 않은 컴포넌트들은 하나의 메소드로만 남겨져 실제 서비스에서 제외됩니다. 다만 사용자가 직접 소스 코드로 메소드를 호출하여 실행할 수 있습니다.

데이터 커넥션

데이터 커넥션은 말 그대로 컴포넌트를 기준으로 한 데이터의 흐름을 나타냅니다.

XAM에서의 모든 데이터는 파라미터로 관리되며 어떤 파라미터가 입력에 사용되며, 컴포넌트 실행 결과로 어떤 파라미터가 출력으로 생성되는지 직관적으로 표현합니다.

파라미터는 하나 이상의 컴포넌트에 input 파라미터로 사용될 수 있으며 output 파라미터 역시 다른 컴포넌트의 input 파라미터로 다시 사용될 수 있습니다.

이벤트 커넥션

이벤트 커넥션은 컴포넌트에 이벤트를 추가할 경우 자동으로 생성되며 이벤트가 추가되었음을 나타냅니다.

예를 들어 2개의 이벤트를 추가할 경우 이벤트 시작과 종료 노드가 생성되며 해당 컴포넌트에 이벤트 커넥션이 연결됩니다. 이벤트의 종류와 사용법은 컴포넌트에 따라 각각 다르며 이벤트 내부에서 역시 원하는 컴포넌트로 비즈니스 로직을 구성할 수 있습니다. 또한, 이벤트에서 호출되는 컴포넌트에서 또 다시 이벤트를 추가할 수도 있습니다.

조건 커넥션

조건 커넥션은 Decision Start 노드에 커넥션이 연결될 경우 자동으로 정의되며, 사용자의 조건코드를 직접 입력하여 이하 컴포넌트의 실행 여부를 결정할 수 있습니다.

if / else if / else 세 가지 타입이 있으며 else를 제외한 조건 커넥션은 사용자가 직접 조건 로직을 코드로 작성할 수 있습니다.

public boolean decisionconnection(ParameterSet globalParemeterSet) throws AutomationFailException {
    int currRowIndex = globalParemeterSet.getIntValue("rIndex");
    DataSet ds = globalParemeterSet.getDataSet("dataset1");

    if (currRowIndex == ds.getRowCount()) {
        return false;
    } else {
        return true;
    }
}

메뉴바 / 개발도구 툴바

XAM 에디터를 위한 메뉴와 툴바에는 자주 사용되는 에디터 메뉴들이 존재합니다. 에디터에서 오른쪽 마우스를 클릭했을 때 나오는 메뉴항목은 다음과 같습니다.

항목

설명

Undo

이전 작업으로 복원

Redo

복원했던 작업 다시 수행

Copy

에디터 노드를 클립보드에 복사

Paste

클립보드에 복사된 항목 붙여넣기

Delete

삭제

Select All

전체 선택

Show All with Alias

모든 Alias를 보여주기

Align

정렬

Align Left / Center / Right / Top / Middle / Bottom

Zoom

확대

Zoom In / Zoom Out

InOutType

In Out Type 정의

In / Out / Normal / In+Out

Save

저장

Save to image file

에디터 화면을 이미지로 저장

Import Parameters

파라미터를 외부에서 가져오기(XML 형식 파일)

Export Parameters

파라미터를 XML형식 파일로 보내기

Validate

모델 Invoke된 항목에 대한 오류 검사

Add BreakPoint

브레이크 포인트 등록

Remove BreakPoint

브레이크 포인트 삭제

Test

모델 테스트 실행

Remote Test

모델 리모트 테스트 실행

Copy Service URL to Clipboard

Service URL을 Clipboard에 복사

Debug

디버그 모드로 실행

Input Test Value

모델 테스트 시 필요한 Input parameter 등록창

Show Properties

프로퍼티뷰 활성화

Outline

Outline은 에디터에서 작성된 정보들을 요약하여 다시 정렬하여 보여줍니다. 또한, Outline과 에디터는 동기화되어 있어서 어느곳에서든 에디터 정보가 변경되면 동일하게 적용됩니다.

Outline의 트리는 크게 다음 두 가지로 구분되어 정렬됩니다.

4.4.3검토(Validate)

X-UP 빌더 는 오토메이션 모델 개발 시 발생할 수 있는 오류를 사전에 방지하기 위한 검토(Validate) 기능을 가지고 있으며 오류 감지 시 해당 노드에 오류 표시(Error Mark)를 표시합니다.

자신을 참조 중인 다른 모델이 존재한 가운데 자신의 주요정보가 변경될 경우 변경전과 변경후의 스키마 비교창을 출력합니다.

레퍼런스가 존재함에도 모델정보를 변경할 경우 참조한 모델 파일과 에디터에서 해당 노드에 에러마크 표시됩니다.

검토(Validate) 체크는 툴바 및 메뉴를 통해 수행할 수 있으며 모델 단위뿐만 아니라 프로젝트 내 모든 모델을 한꺼번에 검사할 수도 있습니다. 에러의 원인이 없어지면 에러마크도 함께 없어집니다.

4.5X-UP View

X-UP 빌더 에서는 다양한 뷰가 존재합니다. X-UP 빌더에서 제공하는 뷰에는 모델 개발시 공통적으로 사용되는 뷰가 있습니다. 모델 개발시 공통적으로 사용되는 뷰는 아래와 같습니다.

4.5.1Result DataSet View

Result DataSet View는 테스트하여 나온 결과 데이터셋의 정보를 테이블 형태로 출력합니다. 만약 데이터셋이 하나 이상 존재할 경우 탭으로 구분하여 출력합니다.

Result DataSet View 는 다음과 같은 작업 후에 결과값을 보여주기 위해 나옵니다.


항목

설명

1

DataSet Tab

하나 이상의 데이터셋이 존재할 경우 데이터셋 이름을 가진 탭으로 구분합니다.

2

DataSet Table

데이터셋 정보

3

Save

데이터셋 정보를 csv 형태의 파일로 저장

4.5.2Outline View

현재 활성화된 에디터에 따른 간략한 정보를 트리 형태로 보여줍니다.

Scrollable Thumbnail은 모델 에디터 Outline view 하단에 출력되며 작업 중인 에디터의 전체 그림을 화면에 맞게 축소시켜 보여줍니다. 또 에디터 화면에서 숨겨진 모습을 포함한 전체 그림을 보여주며, 뷰포인터를 마우스 드래그 하면 에디터 화면을 이동시킬 수 있습니다.

4.5.3Properties View

이클립스에서는 Properties View가 다양한 곳에서 사용됩니다. X-UP 빌더에서는 모델 에디터에서 특정 노드의 속성값을 설정하기 위해 주로 사용합니다.

4.5.4X-UP DataSource View

X-UP DataSource View는 프로젝트내 등록된 데이터소스 정보를 가지고 실제 접속하여 상세 리스트를 조회할 수 있으며 모델 개발 시 드래그 앤 드롭을 통한 빠른 Invoke 생성을 가능하게 합니다. 현재 SAP RFC, DB, X-UP, OData 데이터소스를 지원하고 있으며 앞으로 계속 추가될 예정입니다.

X-UP DataSource View에서 제공하는 기능은 다음과 같습니다.

아이콘

항목

설명

Refresh

워크스페이스에 존재하는 모든 X-UP 프로젝트를 갱신합니다.

Collapse All

펼쳐진 모든 트리를 접습니다.

Link with Editor

선택된 에디터의 모델이 위치한 프로젝트로 자동 선택됩니다.

New DataSource

새로운 데이터소스를 생성합니다.

Go Home

최상위 루트 트리로 이동합니다.

Go Back

상위 트리 노드로 이동합니다.

Go Into

선택된 노드의 하위 트리만 출력합니다.

Select Project

프로젝트를 선택합니다.

Select DataSource

데이터소스를 선택합니다.

Filter

특정 문자열로 필터링합니다.

Show Data

선택된 테이블의 모든 데이터를 조회합니다.

Copy select sql to clipboard

선택된 테이블을 기준으로 기본 select sql를 생성하여 클립보드에 저장합니다.

Copy insert sql to clipboard

선택된 테이블을 기준으로 기본 insert sql를 생성하여 클립보드에 저장합니다.

Copy update sql to clipboard

선택된 테이블을 기준으로 기본 update sql를 생성하여 클립보드에 저장합니다.

Copy delete sql to clipboard

선택된 테이블을 기준으로 기본 delete sql를 생성하여 클립보드에 저장합니다.

Create Select Invoke

특정 테이블을 선택한 후 에디터로 드래그 앤 드롭을 하여 Select Invoke를 빠르게 생성합니다.

Create Modify Invoke

특정 테이블을 선택한 후 에디터로 드래그 앤 드롭을 하여 Modify Invoke를 빠르게 생성합니다

Create Procedure Invoke

특정 Procedure나 Function을 선택한 후 에디터로 드래그 앤 드롭을 하여 Procedure Invoke를 빠르게 생성합니다