27.툴바, 메뉴바, 단축키

Edit

27.1Toolbar 기능

넥사크로 스튜디오는 다양한 기능을 Toolbar 형태로 지원하고 있습니다.

27.1.1Standard

Standard Bar는 넥사크로 스튜디오가 제공하는 기본 기능을 모아놓은 곳입니다.

표 27-1Standard Bar

메뉴

기능

Open Project

Project 열기

Open

넥사크로 스튜디오에서 편집 가능한 형식의 파일 열기

New

새로운 Project나 Application, Form, User Component, css, xml, xjs 등을 생성

Save

현재 열린 Form 문서 저장

Save All

현재 열린 모든 Form 문서 저장

Cut

선택 영역을 잘라내어 클립보드에 저장

Copy

선택 영역을 복사해서 클립보드에 저장

Paste

클립보드에 저장된 내용 붙여넣기

Options

넥사크로 스튜디오의 Options창 표시

About

제품 정보 및 라이선스 입력

27.1.2Align

Align Bar는 Form 화면 개발 시 컴포넌트 정렬 기능을 모아놓은 곳입니다.

표 27-2Align Bar

메뉴

기능

Align Lefts

마지막에 선택된 Component의 Left 값을 기준으로 정렬

Align Centers

마지막에 선택된 Component의 수평 Center 값을 기준으로 정렬

Align Rights

마지막에 선택된 Component의 Right 값을 기준으로 정렬

Align Tops

마지막에 선택된 Component의 Top 값을 기준으로 정렬

Align Middles

마지막에 선택된 Component의 수직 Center 값을 기준으로

정렬

Align Bottoms

마지막에 선택된 Component의 Bottom 값을 기준으로 정렬

Same Width

마지막에 선택된 Component의 Width 값을 기준으로 너비를 맞춤

Same Height

마지막에 선택된 Component의 Height 값을 기준으로 높이를 맞춤

Same Size

마지막에 선택된 Component의 Size를 기준으로 크기 맞춤

Distribute Horizontally

Component 사이를 같은 수평 간격으로 분배 배치.

처음과 끝 Component 사이의 공간을 수평으로 분배하여 균등한 간격으로 Component를 재배치합니다.

Distribute Vertically

Component 사이를 같은 수직 간격으로 분배 배치.

처음과 끝 Component 사이의 공간을 수직으로 분배하여 균등한 간격으로 Component를 재배치합니다.

Distribute Horizontally by Specified Value

Component 사이를 같은 수평 간격으로 정렬 배치.

사용자가 직접 Dialog를 통해 Component의 간격을 조절할 수 있습니다.

Distribute Vertically by Specified Value

Component 사이를 같은 수직 간격으로 정렬 배치.

사용자가 직접 Dialog를 통해 Component의 간격을 조절할 수 있습니다.

Position Center

선택된 Component들을 Form Canvas의 수평 Center로 이동

Position Middle

선택된 Component들을 Form Canvas의 수직 Center로 이동

Position Left

선택된 Component들을 Form Canvas의 Left로 이동

Position Right

선택된 Component들을 Form Canvas의 Right로 이동

Position Top

선택된 Component들을 Form Canvas의 Top으로 이동

Position Bottom

선택된 Component들을 Form Canvas의 Bottom으로 이동


Fit to Contents

선택된 Component들을 컨텐츠와 min, max 속성값에 맞게 크기를 조정합니다.

Bring to Front

선택된 Component를 맨 앞으로 가져오기

Send to Back

선택된 Component를 맨 뒤로 보내기

Bring Forward

선택된 Component를 앞으로 가져오기

Send Backward

선택된 Component를 뒤로 보내기

Arrange to Tab Order

Tab Order 속성값에 따라 Source 코드 내 컴포넌트의 순서를 수정합니다.

Lock Components

Component의 위치를 마우스로 이동하지 못하도록 고정하거나 해제

27.1.3Bookmark

Bookmark Bar는 Script 또는 Source 편집 중에 특정 줄로 쉽게 이동할 수 있는 Bookmark 기능을 모아놓은 곳입니다.

그림 27-1Bookmark Bar

표 27-3Bookmark Bar

메뉴

기능

Toggle Bookmark

현재 커서 위치에 Bookmark를 설정 및 삭제

Previous Bookmark

이전 Bookmark를 찾아 커서를 위치

Next Bookmark

다음 Bookmark를 찾아 커서를 위치

Delete All Bookmarks

설정된 Bookmark를 모두 삭제

Previous Bookmark in Document

현재 편집 창에서 이전 Bookmark를 찾아 커서를 위치

Next Bookmark in Document

현재 편집 창에서 다음 Bookmark를 찾아 커서를 위치

Delete All Bookmarks in Document

현재 편집 창에서 설정된 Bookmark를 모두 삭제

Go to Bookmark

선택한 북마크를 찾아 커서를 위치

Enable/Disable Bookmark

선택한 북마크를 탐색 대상에 포함/제외

Enable/Disable All Bookmarks

모든 북마크를 탐색 대상에 포함/제외

27.1.4Build

프로젝트/폼 단위 빌드 관련 툴바입니다. nexacrodeploy17.exe과 연동된 부분에 대한 처리와 넥사크로플랫폼 앱 실행 부분을 담당합니다.

메뉴

기능

Generate Application

프로젝트 전체를 자바스크립트 파일로 변환합니다. 변환된 파일은 옵션에서 지정된 폴더나 대화상자에서 선택된 폴더에 저장됩니다.

Generate Theme

선택된 테마를 자바스크립트 파일로 변환합니다.

Generate Service

선택된 서비스 그룹을 자바스크립트 파일로 변환합니다.

Generate File

편집 중인 Form 파일을 자바스크립트 파일로 변환합니다.

Stop Generate

진행 중인 변환 작업을 중지합니다.


Screen

실행 시 사용할 Screen 정보를 선택합니다.


Browser

앱 실행 시 사용할 실행 환경을 선택합니다.

NRE, Emulator, 사용자 PC에 설치된 웹브라우저 중에서 선택할 수 있습니다.

Launch

앱을 실행합니다.

QuickView

활성화된 Form을 실행합니다.

27.1.5Debug

Debug Bar는 디버깅 시 필요한 기능을 모아 놓은 곳입니다.

표 27-4Bookmark Bar

메뉴

기능

Start Debugging

프로젝트 디버깅 모드 시작

디버깅 중에는 Continue 기능 수행

Start Form Debugging

현재 선택된 Form의 디버깅 모드 시작

Stop Debugging

디버깅 모드 종료

Restart

디버깅 모드 재시작

Step Into

한 스텝씩 디버그 작업 진행

다른 함수 호출 시 해당 함수로 이동

Step Over

현재 함수의 나머지 부분을 실행하고, 함수 호출이 이루어진 다음 문장에서 멈춤

Step Out

한 스텝씩 디버그 작업 진행

현재 스텝을 모두 실행하고, 다음 스텝으로 이동

Run to Cursor

현재 커서가 위치한 줄까지 실행 후 멈춤

Toggle Breakpoint

브레이크 포인트를 설정/해제하는 기능

Set Conditional Breakpoint

조건부 중단점 설정

Edit Breakpoint

조건부 중단점 설정이 설정된 경우에 해당 설정을 편집

Delete All Breakpoints

설정된 모든 브레이크 포인트를 제거

Go to Source Code

브레이크 포인트 목록 창을 활성화하고 선택된 브레이크 포인트의 소스 코드 위치로 이동

Enable/Disable Breakpoint

선택된 브레이크 포인트를 활성화/비활성화하는 기능

Enable/Disable All Breakpoints

설정된 모든 브레이크 포인트를 활성화/비활성화하는 기능

27.1.6Component

Component Bar는 TypeDefinition에 등록된 컴포넌트 모음입니다. 화면 편집에 해당 컴포넌트를 직접 끌어다 놓음으로써 화면을 구성할 수 있습니다.

Component 툴바에 표시되는 항목은 TypeDefinition Objects 목록에 등록된 컴포넌트에 따라 다르게 보일 수 있습니다. 아래 표시하는 목록은 초기 설치 시 제공되는 목록에 대한 설명입니다.

컴포넌트 선택, 이동

표 27-5컴포넌트

아이콘

이름

설명

Select

하나 이상의 컴포넌트를 마우스로 드래그해서 선택합니다.

Move

Form 디자인 편집 모드에서 화면이 그려지는 캔버스 영역의 위치를 이동합니다.

기본 컴포넌트

표 27-6컴포넌트

아이콘

이름

설명

Button

사용자로부터 마우스 입력을 받을 때 사용하는 컴포넌트

Calendar

날짜를 입력할 때 사용되는 컴포넌트

CheckBox

Check 표시에 대한 TRUE/FALSE 값을 가지는 컴포넌트

Combo

Edit와 Drop down List를 통합한 형태의 컴포넌트

Dataset

데이터를 테이블 형태로 저장하는 컴포넌트

Div

Form 안에 다른 Form을 불러와서 하나의 Form인 것처럼 사용하거나, 관련 있는 컴포넌트들을 하나의 그룹으로 묶어서 처리할 경우 사용되는 컴포넌트

Edit

문자열의 입출력을 가지는 컴포넌트

Grid

스프레드시트와 유사하게 Dataset의 내용을 표 형식으로 처리하는 컴포넌트

GroupBox

화면을 구성할 때 관련 있는 컴포넌트들을 그룹화하는 컴포넌트

ImageViewer

화면에 이미지를 표시할 때 사용되는 컴포넌트

ListBox

항목을 목록으로 나열한 후 선택할 경우 사용되는 컴포넌트.

MaskEdit

날짜의 연월일시(yyyy/mm/dd hh:mi:ss) 형식 또는 숫자의 콤마 표시와 같이 규정된 형식으로 문자열의 입출력을 가지는 컴포넌트

Menu

Menu 아이템을 구성할 경우 사용되는 컴포넌트

Plugin

Plugin을 사용할 경우 사용되는 컴포넌트

PopupDiv

하나의 화면에 여러 개의 부분화면을 구성할 때 사용

PopupMenu

PopupMenu를 구성할 경우 사용되는 컴포넌트

ProgressBar

작업의 현재 진행 상태를 그래픽을 이용하여 보여주는 컴포넌트

Radio

제시된 여러 가지 선택사항 중에서 하나의 항목을 선택해야 할 때 사용하는 컴포넌트

Spin

정해진 규칙에 따라 손쉽게 숫자를 입력받을 때 사용하는 컴포넌트

Static

고정된 텍스트를 표시할 때 사용되는 컴포넌트

Tab

한 화면에서 여러 개의 Tab page를 나눌 경우 사용되는 컴포넌트

TextArea

여러 줄의 문자열의 입출력을 가지는 컴포넌트

DeviceAPI

표 27-7컴포넌트

아이콘

이름

설명

Acceleration

모바일 기기의 가속도 정보

AudioPlayer

모바일 기기에서 오디오 파일을 재생

AudioRecorder

모바일 기기의 오디오를 레코딩하여 파일로 저장

Camera

모바일 기기의 카메라 장비를 연동하여 촬영한 이미지 또는 이미지 경로 처리


Contact

모바일 기기의 연락처 데이터를 처리


ContactAddress

연락처에서 사용되는 주소 필드 오브젝트


ContactField

연락처에서 사용되는 일반 필드 오브젝트


ContactOrganization

연락처에서 사용되는 Organization 필드 오브젝트


ContactPhoto

연락처에서 사용되는 Photo 필드 오브젝트


ContactSet

모바일 기기의 연락처 데이터를 연동하여 처리

ExteralAPI

외부 기기 (혹은 외부 모듈 또는 앱)을 연동하여 실행

FileDialog

사용자가 파일을 열거나 저장할 경로를 선택하기 위한 파일 선택 대화상자

Geolocation

모바일 기기의 위치정보를 제공

ImagePicker

모바일 기기의 사진앨범을 연동하여 저장된 이미지 또는 이미지 경로 처리

LiteDBConnection

모바일 기기에서 지원되는 데이터베이스의 연결 정보 처리

LiteDBStatement

쿼리를 수행하는 오브젝트

Network

모바일 기기의 네트워크 연결정보를 제공

Sms

단문 메시지 서비스(SMS)를 지원하는 오브젝트로 문자메시지 송수신을 처리

Vibrator

모바일 기기의 진동기능을 제공

기타 오브젝트

표 27-8컴포넌트

아이콘

이름

설명


ExcelExportObject

Grid 컴포넌트에 표시되는 내용을 스프레드시트 파일로 내보내는 작업 처리


ExcelImportObject

스프레드시트 파일을 가져와 Dataset 오브젝트로 변환하는 작업 처리

FileDownload

파일 다운로드 작업 처리

FileUpload

파일 업로드 작업 처리


GoogleMap

지정된 위치를 표시하는 지도를 출력하고, 특정위치를 표시

VirtualFile

로컬시스템의 파일을 읽거나 쓰기 위해 사용되는 가상파일 오브젝트


Sketch

캔버스 위에 간단한 도형, 서명 등을 사용자가 그릴 수 있는 오브젝트

WebBrowser

웹브라우저 Wrapper 오브젝트


XPush

X-PUSH 서버 메시지 처리 오브젝트

27.1.7Position

Position Bar는 컴포넌트의 Text, Tooltip, Position을 편집할 수 있는 기능을 모아놓은 곳입니다.

메뉴

기능

ID

컴포넌트의 id 속성값 선택

Text

컴포넌트의 text 속성값 입력

Tooltip

컴포넌트의 tooltiptext 속성값 입력

Left (L)

컴포넌트의 left 속성값 입력

Top (T)

컴포넌트의 top 속성값 입력

Width (W)

컴포넌트의 width 속성값 입력

Height (H)

컴포넌트의 height 속성값 입력

Right (R)

컴포넌트의 right 속성값 입력

Bottom (B)

컴포넌트의 bottom 속성값 입력

Position Editor

컴포넌트의 Position Editor 실행

Position Units

컴포넌트를 선택하지 않은 경우 Position Unit 기본 설정 변경

Edit 컴포넌트의 text 속성처럼 컴포넌트의 속성이 ReadOnly인 경우에는 해당 항목이 비활성화됩니다.

27.1.8SVN

SVN Bar는 서브버전의 기능을 모아놓은 곳입니다.

SVN Bar는 서브버전 클라이언트를 설치한 후 넥사크로 스튜디오의 Tools > Options 창에서 Source Control 항목을 설정해야 활성화되어 사용할 수 있습니다.

그림 27-2svn_toolbar


항목

설명

Update

저장소에 등록된 최신 버전의 파일 내용을 받습니다.

Commit

변경된 내용을 저장소에 반영합니다.

Revert

이전에 수행한 작업을 취소해 파일 상태를 이전 상태로 복구합니다.

Lock

지정된 파일을 다른 사용자가 사용할 수 없는 잠금 설정 상태로 변경합니다.

Unlock

설정된 잠금 설정 상태를 해제합니다.

Import

프로젝트를 저장소에 등록합니다.

Add

새로운 파일을 추가합니다. 추가된 파일은 커밋 명령으로 저장소에 반영할 수 있습니다.

Delete

파일을 삭제 상태로 변경합니다. 커밋 명령으로 저장소에서 제거할 수 있습니다. 사용자 PC에 저장된 실제 파일은 삭제되지 않습니다.

Rename

파일 이름을 변경합니다. SVN에서는 파일명 변경 기능이 따로 있는 것은 아니며 Add/Delete 방식으로 처리합니다.

Edit Conflicts

충돌 상태의 파일을 편집합니다.

Resolve

작업 파일의 충돌을 제거합니다.

Clean up

작업 파일을 재귀적으로 순회하면서 실패한 작업에 대해 무효화 처리합니다.

Refresh Status

파일의 상태를 최신 상태로 변경합니다.

Show Log

파일 변경 이력을 확인합니다.

Compare with Previous Revision

이전 버전과 다른 부분을 비교합니다. Options에서 ‘Program used for diff’ 항목으로 등록된 프로그램이 실행됩니다.

Repository Browser

Repository Browser를 실행합니다.

27.1.9Git

Git Bar는 깃의 기능을 모아놓은 곳입니다.

Git Bar는 Git 클라이언트를 설치한 후 넥사크로 스튜디오의 Tools > Options 창에서 Source Control 항목을 설정해야 활성화되어 사용할 수 있습니다.

그림 27-3svn_toolbar

표 27-9Dataset Editor


항목

설명

Init

현재 열려있는 프로젝트 경로를 Git 저장소로 초기화합니다.

Clone

원격 저장소 프로젝트를 Clone 합니다.

Branch

현재 작업중인 로컬 저장소의 Branch를 변경합니다.

입력한 Branch 명에 해당하는 Branch가 없는 경우 새로 생성하고 변경합니다.

Commit

변경 사항을 로컬 저장소에 반영합니다.

Reset

변경 사항을 취소하고 이전 Commit 상태로 되돌립니다.

Edit Conflicted

충돌이 발생한 파일을 수정합니다.

Refresh

선택한 항목의 상태를 갱신합니다.

Project Log

현재 열려있는 프로젝트의 전체 로그를 확인합니다.

File Log

선택한 파일의 로그를 확인합니다.

Show Diff

최신 Commit과 변경 사항을 비교합니다.

Set Remote

원격 저장소 정보를 설정하고 로컬 저장소와 원격 저장소를 연결합니다.

Unset Remote

로컬 저장소에서 추적중인 원격 저장소의 정보를 삭제합니다.

Pull

로컬 저장소로 원격 저장소의 변경내용을 가져옵니다.

Push

로컬 저장소의 변경사항을 원격 저장소로 발행합니다.

27.2Menu Bar

Menu Bar는 넥사크로 스튜디오에서 제공하는 기능을 모아놓은 곳입니다.

27.2.1File

표 27-10File Menu

메뉴

기능

New


• Project - 새로운 Project 생성

• Application - 새로운 Application Information 생성

• Form - 새로운 Form 생성

• Script (.xjs) - 현재 Project에 새로운 xjs파일 생성

• XML(.xml) - 현재 Project에 새로운 XML 파일생성

• Theme - 현재 Project에 새로운 Theme파일 생성

• Nexacro Style Sheet(.xcss) - 현재 Project에 새로운 Style Sheet 파일생성

• InitValueDefinition(.xiv) - 새로운 InitValue 파일 생성

• UserFont(.xfont) - 새로운 User Font 파일 생성

• View Template - 새로운 View Template 파일 생성

• Model - 새로운 Model 생성

Open


• Project - Project 새로 열기

• File… - 넥사크로 스튜디오에서 편집 가능한 형식(xjs, xcss, xfdl, xtheme 등)파일 열기

Close

현재 열린 Form 닫기

Close Project

현재 열린 Project 닫기

Save

현재 활성화된 편집 화면을 저장하기

Save As


현재 활성화된 편집 화면을 다른 이름으로 저장하기

활성화된 편집화면이 Form인 경우에는 Form Template 또는 Viewset Template으로 저장할 수 있습니다.

Save All

현재 열린 모든 편집 화면 및 Project Explorer에서 변경된 모든 내용을 저장하기

Install Module

모듈 프로젝트에서 생성한 모듈 파일을 설치

Export

Export Wizard를 실행해 프로젝트 내 파일과 템플릿 파일을 묶어서 xpackage 파일로 내보냅니다.

Import

Import Wizard를 실행해 Export 실행 후 내보낸 xpackage 파일을 가져옵니다.

Recent Files

최근에 Open한 File 목록을 표시

Recent Projects

최근에 Open한 Project 목록을 표시

Exit

넥사크로 스튜디오 종료

27.2.2Edit

표 27-11Edit Menu

메뉴

기능

Undo

최종 단계의 이전 상태로 되돌림

Redo

Undo하기 이전 상태로 되돌림

Cut

선택된 영역을 잘라서 클립보드에 복사

Copy

선택된 영역을 클립보드에 복사

Copy ID

선택한 컴포넌트의 ID값을 클립보드에 복사

(디자인모드에서 하나의 컴포넌트 선택 시에만 활성화됩니다)

Paste

클립보드에 있는 내용을 붙여넣기

Paste Special

클립보드에 있는 컴포넌트의 Property 및 Bind정보를 사용자가 선택하여 붙여넣기

Delete

선택된 컴포넌트나 선택된 영역의 텍스트 삭제

Select All

Source나 Script 창에서 모든 텍스트 선택

Find…

Source나 Script 창에서 문자열 찾기

Find in File…

지정경로의 파일 중 지정단어를 포함한 파일 찾기

Replace

Source나 Script창에서 특정 문자열을 다른 문자열로 교체

Goto Line…

Source나 Script창에서 특정 라인으로 커서 이동

Bookmark

Bookmark메뉴에서 제공하는 기능은 Toolbar[Bookmark Bar]의 기능과 동일.

Comment

Selection

Source나 Script창에서 선택된 영역의 문자열을 주석처리

UnComment

Selection

Source나 Script창에서 선택된 영역의 문자열 주석해제

Refresh

파일을 Reload

27.2.3Assist

표 27-12View Menu

메뉴

기능

Show Thumbnail

Form 또는 이미지 선택 시 활성화되며 선택한 항목에 대한 미리보기 이미지 제공

Copy Full Path

선택된 파일이 저장된 경로를 클립보드에 복사

Open Containing Folder

선택된 파일 또는 폴더 위치를 윈도우 탐색기를 열어서 보여줍니다

Open File in Project

프로젝트 내 포함된 파일을 검색하고 직접 실행할 수 있습니다.

Code Snippet

Code Snippet Editor를 실행합니다.

27.2.4View

표 27-13View Menu

메뉴

기능

Toolbars


• Standard - Standard Bar를 표시/숨김

• Bookmark - Bookmark Bar를 표시/숨김

• Align - Align Bar를 표시/숨김

• Build - Build Bar를 표시/숨김

• Debug - Debug Bar를 표시/숨김

• Component - Component Bar를 표시/숨김

• Position - Position Bar를 표시/숨김

Statusbar

Statusbar를 표시/숨김

Project

Explorer

Project Explorer창을 표시합니다. Project Explorer창이 열려있을 때는

focus만 이동합니다.

Resource Explorer

프로젝트에 포함된 리소스 항목을 표시합니다.

Properties

속성창을 표시합니다. 속성창이 열려있을 때는 focus만 이동합니다.

Computed Style

속성창에 Computed Style 탭을 표시합니다.

Bookmarks

Bookmarks 창을 표시합니다.

Component Preset

Component Preset 창을 표시합니다.

Dataset Editor

Dataset Editor 창을 표시합니다.

Easy UI

Easy UI 창을 표시합니다.

Output


• Output - Output창을 표시

• Error List - Error List창을 표시

• Find Result 1,2,3 - Find Result 1,2,3 창을 표시

• Reference - Reference창을 표시

27.2.5SVN

SVN Menu Bar는 서브버전 클라이언트를 설치한 후 넥사크로 스튜디오의 Tools > Options 창에서 Source Control 항목을 설정해야 활성화되어 사용할 수 있습니다.

그림 27-4svn_menu

표 27-14Dataset Editor

메뉴

기능

View


• SVN Output - SVN Output 창을 표시

• SVN Explorer - SVN Explorer 창을 표시

Update

저장소에 등록된 최신 버전의 파일 내용을 받습니다.

Commit

변경된 내용을 저장소에 반영합니다.

Revert

이전에 수행한 작업을 취소해 파일 상태를 이전 상태로 복구합니다.

Lock

지정된 파일을 다른 사용자가 사용할 수 없는 잠금 설정 상태로 변경합니다.

Unlock

설정된 잠금 설정 상태를 해제합니다.

Import

프로젝트를 저장소에 등록합니다.

Add

새로운 파일을 추가합니다. 추가된 파일은 커밋 명령으로 저장소에 반영할 수 있습니다.

Delete

파일을 삭제 상태로 변경합니다. 커밋 명령으로 저장소에서 제거할 수 있습니다. 사용자 PC에 저장된 실제 파일은 삭제되지 않습니다.

Rename

파일 이름을 변경합니다. SVN에서는 파일명 변경 기능이 따로 있는 것은 아니며 Add/Delete 방식으로 처리합니다.

Edit Conflicts

충돌 상태의 파일을 편집합니다.

Resolve

작업 파일의 충돌을 제거합니다.

Clean Up

작업 파일을 재귀적으로 순회하면서 실패한 작업에 대해 무효화 처리합니다.

Refresh Status

파일의 상태를 최신 상태로 변경합니다.

Show Log

파일 변경 이력을 확인합니다.

Compare with Previous Revision

이전 버전과 다른 부분을 비교합니다. Options에서 'Diff Viewer execute file path' 항목으로 등록된 프로그램이 실행됩니다.

Repository Browser

Repository Browser를 실행합니다.

27.2.6Git

Git Menu Bar는 Git 클라이언트를 설치한 후 넥사크로 스튜디오의 Tools > Options 창에서 Source Control 항목을 설정해야 활성화되어 사용할 수 있습니다.

그림 27-5svn_menu

표 27-15Dataset Editor

메뉴

기능

View


• Git Output - Git Output 창을 표시

• Git Explorer - Git Explorer 창을 표시

Init New Repository

현재 열려있는 프로젝트 경로를 Git 저장소로 초기화합니다.

Clone Repository

원격 저장소 프로젝트를 Clone 합니다.

Checkout Branch

현재 작업중인 로컬 저장소의 Branch를 변경합니다.

입력한 Branch 명에 해당하는 Branch가 없는 경우 새로 생성하고 변경합니다.

Commit

변경 사항을 로컬 저장소에 반영합니다.

Reset Changed

변경 사항을 취소하고 이전 Commit 상태로 되돌립니다.

Edit Conflicted

충돌이 발생한 파일을 수정합니다.

Refresh Status

선택한 항목의 상태를 갱신합니다.

Show Project Log

현재 열려있는 프로젝트의 전체 로그를 확인합니다.

Show File Log

선택한 파일의 로그를 확인합니다.

Show Diff

최신 Commit과 변경 사항을 비교합니다.

Set Remote Repository

원격 저장소 정보를 설정하고 로컬 저장소와 원격 저장소를 연결합니다.

Unset Remote Repository

로컬 저장소에서 추적중인 원격 저장소의 정보를 삭제합니다.

Pull

로컬 저장소로 원격 저장소의 변경내용을 가져옵니다.

Push

로컬 저장소의 변경사항을 원격 저장소로 발행합니다.

27.2.7Design

표 27-16Design Menu

메뉴

기능

Align

Space

Size

Position

Fit to Contents

선택된 Component들을 컨텐츠와 min, max 속성값에 맞게 크기를 조정합니다.

Arrange

Arrange to Tab Order

Tab Order 속성값에 따라 Source 코드 내 컴포넌트의 순서를 수정합니다.

Lock Components

Component의 위치를 마우스로 이동하지 못하도록 고정하거나 해제

Zoom


현재 열려있는 화면의 확대/축소 비율 설정

Hotkey List

hotkey 속성값이 지정된 컴포넌트 목록을 편집합니다.

Tab Order Editor (View Type)

컴포넌트의 Tab Order를 수정할 수 있는 편집모드를 시작합니다.

Tab Order Editor (List Type)

컴포넌트의 Tab Order 목록을 표시하고 순서를 변경할 수 있는 창을 띄웁니다.

State View

Tab Order: Form Design화면에 컴포넌트의 Tab Order를 표시합니다

Bind: 컴포넌트의 Bind 상태를 표시합니다.

Position Editor

컴포넌트의 Position Editor 실행

Position Units

컴포넌트를 선택하지 않은 경우 Position Unit 기본 설정 변경

Show Invisible Object Area

Invisible Object 창을 감춘 경우에 해당 창이 보이도록 합니다.

Show Binding Components List

Binding Components List 창을 감춘 경우에 해당 창이 보이도록 합니다.

Align, Space, Size, Position, Arrange 관련 기능은 툴바에서 제공하는 기능과 같습니다.

Toolbar 기능 > Align 설명을 참고하세요.

27.2.8Layout

표 27-17Dataset Editor

메뉴

기능

Add Layout

레이아웃 추가

Copy & Add Layout

선택한 레이아웃 정보를 복사해 새로운 레이아웃을 추가

Delete Layout

선택한 레이아웃 삭제

Rename Layout

선택한 레이아웃의 이름을 변경

Add Step

스탭 추가

Delete Step

스탭 삭제

Easy Design Mode

View 컴포넌트를 포함한 Form을 편집하는 경우 Easy Design Mode 활성화 여부 선택

27.2.9Easy UI

표 27-18Dataset Editor

메뉴

기능

View > Easy UI

Easy UI 창을 표시합니다.

Design


  • Easy Design Mode: View 컴포넌트를 포함한 Form을 편집하는 경우 Easy Design Mode 활성화 여부 선택

  • Trigger Editor: Trigger Item Editor 창을 띄웁니다.

  • Show View Information: Easy Design Mode를 활성화한 상태에서 선택한 View 정보를 보여주는 View Information 창을 띄웁니다.

How to use Easy UI?

온라인 매뉴얼을 연결합니다 (Easy UI 코어)

Let's try Easy UI

Easy UI Tutorial Wizard를 실행합니다.

27.2.10Debug

표 27-19Bookmark Bar

메뉴

기능

View


선택한 디버그 기능 창을 활성화합니다.

Start Debugging

프로젝트 디버깅 모드 시작 <F5>

디버깅 작업을 실행하는 중에는 [Continue]로 항목이 변경됩니다.

Start Form Debugging

현재 선택된 Form의 디버깅 모드 시작 <F6>

Stop Debugging

디버깅 모드 종료

Restart

디버깅 모드 재시작

Step Into

한 스텝씩 디버그 작업 진행

다른 함수 호출 시 해당 함수로 이동 <F11>

Step Over

현재 함수의 나머지 부분을 실행하고, 함수 호출이 이루어진 다음 문장에서 멈춤 <F10>

Step Out

한 스텝씩 디버그 작업 진행

현재 스텝을 모두 실행하고, 다음 스텝으로 이동 <Shift+F11>

Run to Cursor

현재 커서가 위치한 줄까지 실행 후 멈춤

Toggle Breakpoint

브레이크 포인트를 설정/해제하는 기능 <F9>

Set Conditional Breakpoint

조건부 중단점 설정

Edit Breakpoint

조건부 중단점 설정이 설정된 경우에 해당 설정을 편집

Delete All

Breakpoints

설정된 모든 브레이크 포인트를 제거

Go To Source Code

브레이크 포인트 목록 창을 활성화하고 선택된 브레이크 포인트의 소스 코드 위치로 이동

Enable/Disable Breakpoint

브레이크 포인트 목록 창을 활성화하고 선택된 모든 브레이크 포인트를 활성화/비활성화하는 기능

Enable/Disable All Breakpoints

설정된 모든 브레이크 포인트를 활성화/비활성화하는 기능

27.2.11Generate

메뉴

기능

Application

프로젝트 전체를 자바스크립트 파일로 변환합니다. 변환된 파일은 옵션에서 지정된 폴더나 대화상자에서 선택된 폴더에 저장됩니다.

Themes

선택한 테마를 자바스크립트 파일로 변환합니다.

Service

선택된 서비스 그룹을 자바스크립트 파일로 변환합니다.

File

편집 중인 Form 파일을 자바스크립트 파일로 변환합니다.

Stop Generate

진행 중인 변환 작업을 중지합니다.

Regenerate


중복 파일 유무와 상관없이 대상 파일 전체를 변환합니다.

Launch

활성화된 프로젝트를 실행합니다.

QuickView

활성화된 Form을 실행합니다.

Bootstrap Customize

부트스트랩 템플릿 파일을 편집할 수 있는 창을 띄웁니다.

27.2.12Deploy

메뉴

기능

Packing

실행환경별 아카이브 파일을 생성합니다.

- Web Browser

- Windows

- Android

- iOS

- macOS

Build App

운영체제별 앱 설치 파일을 생성합니다.

- Windows (x86, x64)

- Android

- iOS

- macOS

Settings

Deploy, Build 관련 기본 옵션값을 설정합니다.

27.2.13Tools

표 27-20Tools Menu

메뉴

기능

Options

넥사크로 스튜디오의 Options 설정창 열기

27.2.14Window

표 27-21Window Menu

메뉴

기능

Cascade

편집 중인 창을 계단식으로 배치

Tile

편집 중인 창을 바둑판식으로 배치

Arrange Icons

최소화된 아이콘 정렬

Close

선택된 편집 창을 닫기

Close All But This

현재 열려있는 화면을 제외한 모든 화면 닫기

Close Tabs to the Right

현재 열려있는 화면 오른쪽에 있는 모든 화면 닫기

Close All

모든 편집 창을 닫기

Reopen Closed Window

열려있는 프로젝트 내에서 최근에 닫은 화면을 다시 열기

한 번에 하나의 화면 다시 열기를 실행하며 다시 열기를 실행할 대상 화면이 없는 경우에는 해당 메뉴 비활성화

Next

다음 편집 창으로 이동

Previous

이전 편집 창으로 이동

Maximize

편집 창을 최대화

27.2.15Help

표 27-22Help Menu

메뉴

기능

Help

도움말 창을 표시합니다.

Chart 컴포넌트처럼 추가 모듈을 설치한 경우 추가된 모듈 도움말을 선택할 수 있습니다.

Online Manual

온라인 매뉴얼을 웹브라우저에서 실행합니다.

http://docs.tobesoft.com/nexacro_17_ko

About nexacro studio

넥사크로 스튜디오 정보 창 표시

Start Page

최근 프로젝트 목록과 변경된 제품 기능에 관련된 공지를 확인할 수 있습니다.

27.3단축키

넥사크로플랫폼 앱 개발 시 단축키를 사용하여 생산적인 면으로 봤을 때보다 더 빠르게 개발할 수 있습니다. 이 페이지는 유용한 키보드 단축키에 대해서 설명합니다.

27.3.1공통

기능명

단축키

기능설명

New Project

Ctrl + Shift + N

새로운 프로젝트를 생성합니다.

New

Ctrl + N

새로운 Form을 생성합니다.

Open Project

Ctrl + Shift + O

이전에 생성한 프로젝트를 엽니다.

Open

Ctrl + O

이전에 생성한 파일을 엽니다.

Save

Ctrl + S

파일에서 수정한 내용을 저장합니다.

Save All

Ctrl + Shift + S

모든 파일에서 수정한 내용을 저장합니다.

Copy

Ctrl + C,

Ctrl + Ins

선택된 내용을 Clipboard에 복사합니다.

Cut

Ctrl + X,

Shift + Del

선택된 내용을 잘라내어 Clipboard에 복사합니다.

Paste

Ctrl + V,

Shift + Ins

Clipboard의 내용을 붙여넣습니다.

Delete

Del

선택된 내용을 삭제합니다.

Select All

Ctrl + A

모든 항목을 선택합니다.

Undo

Ctrl + Z,

Alt + Back

바로 이전 작업상태로 되돌립니다.

Redo

Ctrl + Y

바로 전에 작업한 내용을 반복합니다.

Find in Files

Ctrl + Shift + F

"Find in Files" 창을 띄웁니다.

Open File in Project

Alt + Shift + O

"Open File in Project" 창을 띄웁니다.

Project Explorer

Ctrl + Alt + L

"Project Explorer" 창을 띄웁니다.

Resource Explorer

Ctrl + Shift + E

"Resource Explorer" 창을 띄웁니다.

Properties

Alt + Enter

"Properties" 창을 띄웁니다.

Computed Style

Ctrl + Alt + C

"Computed Style" 창을 띄웁니다.

Bookmark

Ctrl + W

"Bookmark" 창을 띄웁니다.

Dataset Editor

Ctrl + D

"Dataset Editor" 창을 띄웁니다.

Output

Alt + 2

"Output" 출력 창을 띄웁니다.

Error List

Ctrl + \

"Error List" 창을 띄웁니다.

Help

F1

넥사크로플랫폼 도움말(레퍼런스 가이드)이 나타납니다.

Online Manual

Ctrl + F1

넥사크로플랫폼 온라인 매뉴얼을 웹브라우저에 띄웁니다.

Launch (Screen)

Ctrl + F5

현재 열려있는 프로젝트를 지정한 Screen 정보로 실행한다.

Exit

Alt + F4

넥사크로 스튜디오를 종료합니다.

27.3.2Window

기능명

단축키

기능설명

Next Window

Ctrl + Tab

열려있는 다음 파일을 활성화합니다.

Previous Window

Ctrl + Shift + Tab

열려있는 이전 파일을 활성화합니다.

Expand Max View

Ctrl + Shift + Enter

모든 도킹창을 최소화하고 현재 윈도우를 최대화합니다.

Change Tab Next

Ctrl + Page Down

해당 탭 바로 다음 탭으로 이동합니다.

(Design/Source/Script)

Change Tab Previous

Ctrl + Page Up

해당 탭 바로 이전 탭으로 이동합니다.

(Design/Source/Script)

27.3.3Project Explorer

기능명

단축키

기능설명

Rename

F2

Project Explorer에서 선택된 Item의 이름을 변경합니다.

Search

F3

입력된 Filter Keyword를 포함한 Item을 선택합니다.

27.3.4Properties Window

기능명

단축키

기능설명

Show Items

Ctrl + F4

선택된 Property의 값이 Combo로 표시된다면, Combo의 내용을 펼쳐서 표시합니다.

27.3.5Form Design

기능명

단축키

기능설명

Escape

Esc

현재 작업을 취소합니다. (현재 작업이 없다면 선택된 컴포넌트의 상위 컴포넌트를 선택합니다)

Next

Tab

선택된 컴포넌트의 다음 Tab Order의 컴포넌트를 선택합니다.

Previous

Shift + Tab

선택된 컴포넌트의 이전 Tab Order의 컴포넌트를 선택합니다.

Move

방향키 ↑,↓,←,→

선택된 컴포넌트를 상,하,좌,우로 이동합니다.

Move(minutely)

Ctrl + 방향키

↑,↓,←,→

선택된 컴포넌트를 상,하,좌,우로 미세하게 이동합니다.

Resize

Shift + 방향키

↑,↓,←,→

선택된 컴포넌트의 사이즈를 변경합니다.

Resize(minutely)

Ctrl + Shift + 방향키 ↑,↓,←,→

선택된 컴포넌트의 사이즈를 미세하게 변경합니다.

InplaceEdit

F2

선택된 컴포넌트의 Text를 변경할 수 있는 InplaceEdit를 활성화합니다.

Select All

Ctrl + A

전체 컴포넌트들을 선택합니다.

Hotkey Editor

Ctrl + H

전체 컴포넌트의 Hotkey 편집기를 띄웁니다.

Tab Order Editor (View Type)

Ctrl + T

View 타입의 Tab Order 편집 모드를 활성화합니다.

Tab Order Editor (List Type)

Ctrl + Shift + D

Tab Order 편집기를 띄웁니다.

Bind State View

Ctrl + B

컴포넌트들의 Bind 정보를 표시합니다.

Quick View

Ctrl + F6

현재 Form을 실행합니다

Copy ID (Include Parent)

Ctrl + Shift + C

선택된 컴포넌트의 ID 텍스트를 복사합니다.

Paste Special

Ctrl + Shift + V

Paste Special을 실행합니다.

27.3.6Debug

기능명

단축키

기능설명

Start Debugging

F5

디버깅을 시작합니다.

Stop Debugging

Shift + F5

디버깅을 중지합니다.

Restart

Ctrl + Shift + F5

디버깅 모드를 재시작합니다.

Step Into

F11

한 스텝 디버그 작업 진행합니다.

(다른 함수 호출 시 해당 함수로 이동)

Step Over

F10

현재 함수의 나머지 부분을 실행하고, 함수 호출이 이루어진 다음 문장에서 멈춥니다.

Step Out

Shift + F11

한 스텝 디버그 작업 진행합니다.

(현재 스텝을 모두 실행하고, 다음 스텝으로 이동)

Run to Cursor

Ctrl + F10

현재 커서가 위치한 줄까지 실행 후 멈춥니다.

Start Form Debugging

F6

Form을 디버깅합니다

27.3.7Migration

기능명

단축키

기능설명

Migration Log

Ctrl + Shift + M

Migration Log 창을 띄웁니다.

27.3.8Source/Script

기능명

단축키

기능설명

Find

Ctrl + F

특정 키워드를 찾는 Find Dialog 기능을 활성화합니다.

Find Next

F3

현재 커서 위치에서 Find 기능으로 찾은 키워드의 다음 위치를 찾습니다.

Find Previous

Shift + F3

현재 커서 위치에서 Find 기능으로 찾은 키워드의 이전 위치를 찾습니다.

Find Word

Ctrl + F3

현재 커서 위치에서 선택된 키워드와 같은 문자열의 다음 위치를 찾습니다.

Go to Line

Ctrl + G

입력된 라인으로 이동합니다.

Match Brace

Ctrl + ]

현재 선택된 Brace에 매치되는 Brace로 커서가 이동됩니다.

Match Brace(select)

Ctrl + Shift + ]

현재 선택된 Brace에 매치되는 Brace로 커서가 이동하면서 이동영역을 모두 선택합니다

Replace

Ctrl + R

특정 키워드를 다른 키워드로 변경하는 Find and Replace Dialog 기능을 활성화합니다.

Select All

Ctrl + A

현재 파일 내 모든 내용을 선택합니다.

Comment Selection

Ctrl + /

선택된 영역을 주석으로 변경합니다.

Uncomment Selection

Alt + /

선택된 영역의 주석을 해제합니다.

Lowercase Conversion

Ctrl + U

선택한 영역의 텍스트를 소문자로 변환합니다.

Uppercase Conversion

Ctrl + Shift + U

선택한 영역의 텍스트를 대문자로 변환합니다.

Toggle Bookmark

Ctrl + F2

현재 파일 내 원하는 지점에 Bookmark를 설정/해제 합니다.

Clear Bookmarks

Ctrl + Shift + F2

현재 파일 내 설정한 모든 Bookmark를 제거합니다.

Next Bookmark

F2

현재 파일 내 설정한 다음 Bookmark를 따라갑니다.

Previous Bookmark

Shift + F2

현재 파일 내 설정한 이전 Bookmark를 따라갑니다.

Delete Line

Ctrl + Shift + L

커서가 위치한 현재 라인을 삭제합니다.

Delete Line (left of the cursor)

Ctrl + Shift + Back

현재 라인에서 커서 기준 좌측 내용을 삭제합니다.

Delete Line (right of the cursor)

Ctrl + Shift + Del

현재 라인에서 커서 기준 우측 내용을 삭제합니다.

Delete Paragraph

Ctrl + Del

커서의 위치를 기준으로 단락 단위로 삭제합니다.

Tab

Ctrl + Shift + I

Tab와 같은 기능

Move Start Position of Line

Home

공백을 제외한 라인의 시작 위치로 커서를 이동시킵니다.

Select Start Position of Line

Shift + Home

라인의 시작 위치까지 선택영역을 확장시킵니다.

Move End Position of Line

End

라인의 마지막 위치로 커서를 이동시킵니다

Select End Position of Line

Shift + End

라인의 마지막 위치까지 선택영역을 확장시킵니다.

Move Start Position of File

Ctrl + Home

현재 파일의 시작 위치로 커서를 이동시킵니다.

Select Start Position of File

Ctrl + Shift + Home

현재 파일의 시작 위치까지 선택영역을 확장시킵니다.

Move End Position of File

Ctrl + End

현재 파일의 마지막 위치로 커서를 이동시킵니다.

Select End Position of File

Ctrl + Shift + End

현재 파일의 마지막 위치까지 선택영역을 확장시킵니다.

Paragraph Next

Ctrl + \

다음 단락 위치로 커서를 이동시킵니다.

Paragraph Previous

Ctrl + /

이전 단락 위치로 커서를 이동시킵니다.

Zoom

Ctrl + -(num), +(num)

파일 내용을 확대하거나 축소해서 표시합니다.

Zoom Default

Ctrl + /

배율을 100%로 적용합니다.

Intellisense

Ctrl + Space

Intellisense 기능을 활성화합니다.

Toggle Breakpoint

F9

현재 파일 내 원하는 지점에 중단점을 설정/해제합니다.

Delete All Breakpoints

Ctrl + Shift + F9

중단점을 모두 삭제합니다.

Enable/Disable Breakpoint

Ctrl + F9

중단점을 사용하지 않도록 설정합니다.